Elastic Search stack is not working in azure platform


(rahul ranjan) #1

Elastic Search stack is not working in azure platform.


(David Pilato) #2

Is it a question?

I mean: do you need help?

If so, may be you could share information about what you did, the logs, ... ?


(rahul ranjan) #3

Hi Team,

I had installed the elastic search in the azure platform. But I am unable to open the elastic from outside and my aim is collect the log from azure service. Can you help me on this please?

Thanks,

Rahul Ranjan


(Tim Vernum) #4

I have removed your contact details as this is an open forum.

If you want assistance, then you will need to provide a clear description of what steps you have taken and the errors you are seeing. This forum provides free support, without any SLA guarantees, so it is on your best interests to do everything you can to explain what is going on so that we have the best chance of being able to help.


(rahul ranjan) #5

yes this is question.

I need help here.

Which type of logs you need for that. can you support on skype and zoom for this.

I installed it from azure marketplace. I can see the kibana is working. but when I try to send logs from other system. It is not accessible. so basically I am having problem in port (9200) opening problem in azure.

and also please confirm Can I view the log of app service in azure? if yes then please step?


(David Pilato) #6

No. We, elastic, do sell support.

That's may be an "azure" problem. You need to open port 9200 to the system which is sending your logs. Check on that system that you can access to http://IP:9200 where IP is the IP address of your machine.

Make sure you are not exposing your cluster on internet, at least without any security.


(Sandeepkanabar) #7

Are you accessing Kibana over port 5601? As @dadoonet suggested, do a simple curl http://IP:9200 or telnet IP:9200 to determine if the port is open.


(rahul ranjan) #8

Then How can I solve the problem? I checked the port no 9200 is not available from outside. When I connected to azure support. they are saying we can not help on this. only elastic search support guys will help on this.


(David Pilato) #9

What are the logs of your elasticsearch instance?


(Tim Vernum) #10

How did you install elasticsearch? Did you use an ARM template, or something else?
Please provide details, otherwise we're just guessing.


(rahul ranjan) #11

Yes I used the ARM Template.


(rahul ranjan) #12

Step to Reproduce :wink:

Go to Azure Search box :
(1) Type the Elastic Stack - ElasticSearch, Kiban and logstash
(2) Install the all template with 3 node.
(3) after that open the port 5601 : It is working
(4) Open the port 9200 in ESkibana-nsg. But I gessing telnet is not working from outside.


(Russ Cam) #13

@rahul.ranjan When you install the ARM template through the Azure Marketplace, you can choose the load balancer type also deployed

  • internal - deploys an internal load balancer that is addressable only on the virtual network, and will be what Kibana will use to communicate with the cluster. The internal load balancer can also be used by any other resources that you have hosted in Azure and can be connected to the same virtual network
  • external - deploys an external load balancer that will allow communicating with the cluster over a public IP address on port 9200. If you need to communicate with Elasticsearch from outside of Azure, you may also want to choose this option. Note that this option will also deploy an internal load balancer for Kibana to use to communicate with the cluster.

Kibana is deployed with its own Network Security Group that opens only ports 5601 and 22, and a public IP address to allow you to connect to Kibana from the public internet.

Take a look at the documentation on load balancer types for further details. If you're deploying the template fro GitHub directly using the Azure CLI, there is a third load balancer type, gateway, that configures Application Gateway as a publicly facing load balancer.