Elasticsearch as a service - Linux


#1

I have Elasticsearch, Kibana, Logstash all up and running on seperate linux boxes. I first started with installing them and then launching them all individually. But I need to have each box launching them as a service.

I've tried sudo service elasticsearch, but it does nothing...

Any help would be grateful.


(Magnus Bäck) #2

But I need to have each box launching them as a service.

How did you install ES and the others?

I've tried sudo service elasticsearch, but it does nothing...

Does nothing? You don't even get an error message?


#3

I pretty much installed them like this: A guide I was making for an intern of mine. No error message. Just goes to next command line

Step 1) Install Java 7 or later
a) Run command (sudo add-apt-repository -y ppa:webupd8team/java)
b) Run command (sudo apt-get update) to update Java
c) To check what Java version run command (java –version)
Step 2) Download Elasticsearch files
a. Through linux command go and download files by running the command below:
curl -L -O https://download.elastic.co/elasticsearch/elasticsearch/elasticsearch-1.7.1.tar.gz
b. Now extract .tar file, run command (tar -xvf elasticsearch-1.7.1.tar.gz)
Step 3) Locate and Run Elasticsearch
a) Find Elasticsearch install files in the same directory you were in when downloading files
b) Open Elasticsearch directory with (cd Elasticsearch-1.7.1)
c) Open bin directory next (cd bin)
d) Run Elasticsearch from bin directory using (./elasticsearch)


#4

I also followed

https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-service.html


(Magnus Bäck) #5

If you have an RPM or Debian based distribution I strongly suggest that you use the available packages instead.


#6

So if I started off using the basic install methods and want to use debian, is it best to start from scratch?


(Magnus Bäck) #7

Unless you have data you need to keep I'd just ignore the current files. If you want to keep the data you can copy the files in the data directory to where the Debian package puts them (under /var/lib/elasticsearch). Just make sure file ownership etc is correct.


#8

K, I got Elasticsearch running as a service and Kibana on different VM's and I switched the kibana.yml elasticsearch to urlname:9200 but the UI is not working. Says site is down error...

Ideas? What might i be forgetting?


(system) #9