Elasticsearch is restarting like a loop after I remove x-pack security

I downloaded using docker like this and the version I'm using is 5.6.8
docker run --name elasticsearch \
-p 9200:9200 \
-p 9300:9300 \
-v /opt/esdata:/usr/share/elasticsearch/data \
-e xpack.security.enabled="false" \
--restart always \
-d docker.elastic.co/elasticsearch/elasticsearch:5.6.8

source directory

after that Elasticsearch worked for me until I remove x-pack

after I removed x-pack security like this
docker exec -i -t elasticsearch bash
elasticsearch-plugin remove x-pack
docker restart elasticsearch

the error when I getting from elasticsearch logs
Caused by: java.lang.IllegalArgumentException: unknown setting [xpack.security.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

I should remove x-pack and run elasticsearch without any issues because I don't need it anymore so please give me a solution .

Thanks .

As the above said, now that the xpack plugin is not installed , there is no xpack.security.enabled configuration setting, so setting it is wrong. Remove the

-e xpack.security.enabled="false" 

part from your docker run command.

after now i'm getting this error
ERROR: [1] bootstrap checks failed
[1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

for that I just tried this command
sudo sysctl -w vm.max_map_count=262144

still it's getting restart !

what should I wanna do sir ?

Not sure what that means, you need to share the actual error you get.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.