Elasticsearch node going offline after installing x-pack in kibana


(Praneeth) #1

Hi,

Elastic search version - 5.5.1
Kibana version - 5.5.1
x-pack version - 5.5.1

System: centos, Running in a VM

System RAM: 3000MB
Single core processor

First, I have installed elastic search with x-pack(trail version) configured with

xpack.shield.audit.enabled: true

Then, it is running good and not going down.

After that trying to install kibana with x-pack in the same node, in which elasticsearch was running.
Elastic search started as /bin/elasticsearch -d option.

What I noticed is, when i try to install x-pack plugin in kibana, the elastic search that is running background is going offline. I have observed it 3 to 4 times, the same thing is happening.

And the log shows

[2018-06-21T05:16:59,676][INFO ][o.e.x.m.j.p.NativeController] Native controller process has stopped - no new native processes can be started

So, why the elasticsearch process is killing itself after installing kibana with x-pack. Is there no sufficeint ram available for elastic search(at present on running top nearly 2gb ram is being used for elastic search) since installing elasticsearch and kibana on the same node.

Can some one please help in resolving this issue


(Ioannis Kakavas) #2

This can certainly be resource related.

What are your JVM heap options ( look at your jvm.options file inside your Elasticsearch config dir ) ?
Can we get the full error stack from your logs ?


(Praneeth) #3

JVM configuration

################################################################
## IMPORTANT: JVM heap size
################################################################
##
## You should always set the min and max JVM heap
## size to the same value. For example, to set
## the heap to 4 GB, set:
##
## -Xms4g
## -Xmx4g
##
## See https://www.elastic.co/guide/en/elasticsearch/reference/current/heap-size.html
## for more information
##
################################################################

# Xms represents the initial size of total heap space
# Xmx represents the maximum size of total heap space

-Xms2g
-Xmx2g

The above is myjvm.options file.

Now, when I am trying to install the x-pack plugin in kibana, the elastic search process is running with -d option, I have found that installation requires 4 GB(2 gb for elastic search and nearly 1 GB for x-pack installtion in kibana and nearly 1gb for system process). It installed good and the elastic search process is not stopped in it while installation, it has 6000MB RAM

Is there any chance that the elastic search process can go down by itself, because of only 3000MB is available??

And for the log you have asked, that is the last statement I can find after the node goes down


(Ioannis Kakavas) #4

The file you copy pasted here contains the following :

If you read this documentation it clearly says:

Set Xmx to no more than 50% of your physical RAM, to ensure that there is enough physical RAM left for kernel file system caches.

You have 3GB so setting

-Xms1g
-Xmx1g

would be more sensible

I know, I was interested in the other messages before that that could contain more helpful information.

Sorrym but I'm not sure I follow what you're saying here. What has the 6GB of RAM ? I thought your VM has 3GB.
If you can't assign more RAM to the VM, then stop Elasticsearch service before attempting to install X-Pack in Kibana and then start it again


(Praneeth) #5

Thanks for your reply.

What has the 6GB of RAM ? I thought your VM has 3GB.

In 3GB node, I have observed that elastic search is stopping so many times, when kibana is also running on it. So, I have created another 6GB instance, to verify what is the problem


(Ioannis Kakavas) #6

So as you have figured out , 3GB is not enough to run Elasticsearch with your current settings. Try the suggestions in my post above and see if it helps


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.