Problem installing x-pack on Centos 7 virtual box vm

I have elasticsearch 6 and kibana running on a test machine. It is a virtualbox vm running Centos 7. Everything runs fine until I run the kibana-plugin command to install x-pack. It runs fine until it gets to: Optimizing and cacheing browser bundles... It runs for about 5 mins and then reports Killed.

I thought it might be the size of the vm, it currently is running on a 4 processor 4GB vm. This is the second day I have been reading about elastic search, have done some preliminary google searches, and searches on this site but so far I have haven't found out what might be causing it. I tried logging, but the logs were jason formatted and hard to read, so I am looking at logging levels and installed jq to help with the logs.

I was wondering if someone had an idea as to the cause of the problem, it would save time. I am so new to elasticsearch, that at the moment I am just trying to get the basics down, so I don't have a feel for the app yet.

Hi Edward,

I just verified that the setup you describe can be installed with no issue. Virtualbox with

  • CentOS-7-x86_64 ( 3.10.0-693 )
  • 1 cpu
  • 4 GB RAM

The optimizing and caching browser bundles takes a few minutes but completes without errors.

Can you share some of the logs so that we can assist you to get to the bottom of this ?

Thanks for checking. Did you follow the installation instructions found on this page?

I did not make any system configuration changes, and just went down the list as shown. Although I did not have 4 G ram the first time.

Which log is most useful? Kibana does not output a log without configuring it to do so, and is the standard logging level enough? I don’t have time at the moment to get the logs, but knowing it should work is half the battle. I will start over again, set up logging for Kibana, and if it does not work, I will ship the logs.

I appreciate the help. The setup for the ELK stack is amazingly simple for such a powerful program. I just started reading about it, and took a couple of Udemy Courses. Along with’s documentation, it has been an interesting learning exercise.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.