Install problem -- kibana-plugin appears to hang


(Wayne Morrison) #1

Installing:

  • elasticsearch-6.2.4
  • kibana-6.2.4-linux-x86_64
  • on Linux 7.4 running on VirtualBox, which is running on OSX 10.13.4

I've been trying to install elasticsearch and have been having problems. I've been through the basic tutorial on elastic.co, and it gave instructions for installing both Elastic and Kibana. The Elastic install seemed to work without problem.

The Kibana install, however, had problems when installing the recommended x-pack plugin.

It downloads and extracts a bunch of files. It tries to set up some caching. And it sits there forever.

I don't know what it's doing, but it's doing something. It may be spinning its wheels, but it's chewing up the cycles pretty well.

Here's what happens when I run the command as instructed:

    $ bin/kibana-plugin install x-pack
    Attempting to transfer from x-pack
    Attempting to transfer from
    https://artifacts.elastic.co/downloads/kibana-plugins/x-pack/xpack-6.2.4.zip
    Transferring 264988487 bytes....................
    Transfer complete
    Retrieving metadata from plugin archive
    Extracting plugin archive
    Extraction complete
    Optimizing and caching browser bundles...

And then nothing further is displayed.

I've tried this several times and it always (appears) to act the same. The most recent time I tried, I let it run for almost five hours before I killed it. There was no apparent activity, except that keyboard/mouse response time slowed to almost no response at all.

Has anyone seen similar behavior? Does it really take that long to do the optimization? Is Kibana really necessary to run Elastic?

Thanks for the assistance.


(Tyler Smalley) #2

Unfortunately, the optimizing process is very CPU intensive and I have seen it take up to 10 minutes to complete. How long have you let it run for? We hope to remove the need for this process entirely in the coming months.


(Wayne Morrison) #3

My last run was for almost five hours.

I let the machine sit while kibana-plugin ran, because I thought it might take a while for the run to complete. I just wasn't expecting it to take quite that long. I eventually killed the run because I figured that something must be wrong, and chewing up computrons for so long, no end in sight, didn't seem productive.


(Tyler Smalley) #4

Do you have any other plugins installed?


(Wayne Morrison) #5

I was watching this intro video https://www.elastic.co/webinars/getting-started-elasticsearch?elektra=rtp&storm=learn&iesrc=ctr and following the instruction it had. I'd installed Elastic as it showed, and was doing the same with Kibana. The Elastic x-pack had been installed, according to directions, but nothing else.


(Wayne Morrison) #6

By the way, I've tried installing kibana multiple times and the same problem described above has always happened.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.