X-pack install 5.5.1 memory full


(yaoqijun) #1

i install x-pack in elastic 5.5.1 and win10,

after is execute elasticsearch-plugin install x-pack, one process start

then all memory be used, my computer is down, any help ???????

waiting online


(David Roberts) #2

I'm not sure why the controller.exe process would be using so much memory. It's a very simple process and shouldn't use anything like this amount. On a Windows Server 2012r2 machine I just ran it and it used 1436K, so yours is using about 3000 times more.

I suspect it's something related to your locale, so maybe if you could describe your setup that would help us reproduce the problem and fix it. So:

  1. Which language is your computer set to?
  2. Are you running Elasticsearch as a service or from a command prompt?
  3. If from a command prompt, what is the character set codepage of that command prompt?

In the meantime, if you don't require the Machine Learning feature, a temporary fix would be to set xpack.ml.enabled: false in elasticsearch.yml, delete the file %ES_HOME%\plugins\x-pack\platform\win-x86_64\bin\controller.exe and restart Elasticsearch.


(yaoqijun) #3

thanks, i have solve the problem with installing es, kibana, x-pack in VMware,
i develop in windows, so in windows en , i setting

xpack.ml.enabled: false
xpack.security.enabled: false
xpack.monitoring.enabled: true
xpack.graph.enabled: false
xpack.watcher.enabled: false

still memory gradually increase to my max memory 16G
maybe my windows env something wrong,
thank you anywhere


(Phy) #4

I have the same issue.

  • xpack.ml.enabled: false is set (actually if I don't do this under Windows elasticsearch won't start);
  • I am under a Chinese environment;
  • I started Elasticsearch from a command prompt with a codepage of 936 (GBK).

Maybe I should try deleting controller.exe?

Edit: Force kill controller.exe process seems OK.


(Sophie Chang) #5

Hi @phy25

We are looking into this issue, and in the meantime, please follow the steps repeated below, and delete the controller.

Thanks for the additional info about your setup.

Sophie


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.


(David Roberts) #7

(David Roberts) #8

We have found the cause of this problem and fixed the code. The fix will be released in future patches of all versions of the stack from 5.5 upwards. At the moment I cannot confirm the exact patch versions the fix will be in, but will update this post when I know, and the fix will also be listed in the release notes.


(David Roberts) #9

This problem is resolved in version 5.6.2.


#10

Hi Everyone,

I am using 5.6.4 and I am wondering if I am seeing this problem. If I enable xpack security the memory usage of my Elasticsearch Docker container goes up and up and eventually the Docker is killed by Mesos.

Note: this ONLY happens when xpack security is enabled.

--John


(David Roberts) #11

@hokiegeek2 this topic originally discussed a Windows-only problem. Since your problem is in Docker it must be different so please start a new topic.


#12

Hi David,

It's possible that Docker has something to do with it, but I am a bit skeptical. I am running Elasticsearch on CentOS within a Docker and I can clearly see the memory usage go up and up until Mesos kills it when the Docker requests more RAM that allotted. I think that Docker on Mesos just provides the memory boundary to the problem. I will, however, test outside of docker just in case.

Also, I know that elastic offers Elasticsearch on Docker. If this is a Docker issue, would this not have been reported already? If so, can you reference a JIRA ticket that has the resolution?

Thanks

--John


(David Roberts) #13

This topic is discussing a specific problem in the machine learning code that was caused by inappropriate handling of a particular type of error on non-English Windows. Please open a new discussion topic to discuss different problems.


(David Roberts) #14