ELK versions compatibility matrix


(Sunil Chaudhari) #1

Hello,
Is there any matrix/table which tells us, say for example Logstash-1.5.5 version is compatible with ES-1.5.x or 1.x.x.
Kibana-1.4 is compatibel with ES-2.x.x etc.

Please provide if we have it.
Currently I am using Logsatsh-1.5.3. But for FIlebeat, I have to upgrade to LS-1.5.4 or above. I am afraid if it will ask me to upgrade ES and Kibana as well.

br,
Sunil.


(Mark Walkom) #2

https://www.elastic.co/subscriptions/matrix


(Carlos Vega Moreno) #3

I need this too, I would like to know if kibana 4.4 will work on elasticsearch 2.1.1


(Mark Walkom) #4

Please see that link I posted.


(Neelabh Singh) #5

https://www.elastic.co/support/matrix#show_compatibility


(system) #6