Empty Agent policy

Hi! I can't select a policy for fleet, I've tried to reinstall the whole Stack but it doesn't work either.

The problem:

The default policies:

Hi nestro,

It looks like something has gone wrong with your Fleet setup as "Default Fleet Server policy" should have the Fleet Server integration added.

You can fix this by going into "Default fleet server policy" -> Add Integration -> Fleet Server -> add integration.

I think the policy should then appear in the dropdown,

Let me know how you get on!


Thanks for the fast reply! When I'd like to add an integration the following problem appears and beacuse of that I can't find the Fleet integration:

Is your kibana installation able to connect to the internet? By default Kibana downloads package metadata and content from the public Elastic Package Registry at epr.elastic.co.

Not being able to connect to the registry is what has prevented the Fleet Server integration being added on Fleet setup.

If you are in an air-gapped environment, there are some instructions to help here:

Hope that helps,


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.