Unable to choose Fleet Agent Policy

Hello everyone,

I'm trying to get a Fleet server set up on my on-premise stack for the first time. Server and Agent are RPM installed with version 7.16.1.

When setting up the Fleet server, I am unable to select an Agent Policy. The drop-down seems to be disabled/empty, though I do have the default policies as well as a custom policy.

Agent enrollment stalls on "Fleet Server - Waiting on fleet-server input to be added to default policy", which I'm guessing is due to the fact I can't select an Agent Policy in the setup.

Would definitely appreciate some help.

Figured it out. Always love the irony when this happens...

Solution was to add a "Fleet Server" integration to a policy and it was then available as an option when setting up the Fleet Server.


Hi there,

Glad you were able to figure this out!

This is a strange issue you ran into, and there's definitely some improvements we could make here. By default, Fleet should be creating a policy with this integration already configured so that it's available in this dropdown. By chance, do you know if you deleted the "Default Fleet server policy" at any point?

It's entirely possible I had deleted the default/original policy at some point, but can't say for sure. I know I took a stab at the Elastic Agent/Fleet setup early on in my Elasticsearch journey and quickly realized I should stick with the basics for a bit first (Beats made more sense to my brain at the time). So as I said, it is possible I deleted the default at that time while trying to figure things out.

Sorry that I can't be more help on that level!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.