#/error/url-overflow in kibana 5.6


(Shivendra Prakash Shukla) #1

Kibana version: 5.6

Elasticsearch version: 5.6

Browser version : Edge/IE11

Browser OS version: Win10

When I will try access the kibana through the IE or Edge Browser that time URL-Overflow error shouldn't happen often ;), we've noticed that Kibana redirects to /#/error/url-overflow instead of /{basepath}/#/error/url-overflow. But other browsers it's working fine.

Errors in browser console (if relevant):
none

Provide logs and/or server output (if relevant) :
none


(Marius Dragomir) #2

This is because there is a limit to maximum URL size in IE and earlier version of Edge. For this, there is a setting in Advanced Settings, called state:storeInSessionStorage which will store the state in session storage instead of the URL. This way you won't get the error.


(Shivendra Prakash Shukla) #3

How to fix through the code? Please suggest me.


(Shivendra Prakash Shukla) #4

Hi Marius ,

since I change setting "state:storeInSessionStorage" to true.
after that i am getting different error becoz of this changes
"Unable to completely restore the URL, be sure to use the share functionality.".

Please suggest how i will fix it....