Increase URL_MAX_OTHERS to avoid URL overflow error


(Arun A Nayagam) #1

Hi,

I am using Kibana 4.6.1.

I am intentionally trying to execute a large boolean query.
I am getting a URL overflow error, defined here, ./src/ui/public/error_url_overflow/url_overflow_service.js

I don't know how to increase that. Is there a way to do that?

If changing the value in url_overflow_service.js and building kibana is the only solution, can you either please list the step to build (I have no clue about building such projects) or point me to a resource of how to build. Please don't point me here -- https://github.com/elastic/kibana/blob/master/CONTRIBUTING.md
I don't understand that.

I have already changed index.query.bool.max_clause_count of Elasticsearch so the search as such is not an issue.

Thanks,
Arun


(Arun A Nayagam) #2

Hi All,

I found the solution, I had a older version of Kibana 4.6.1

This post suggests that the fix for the URL overflow was provided to 4.6.1,

So I installed the latest 4.6.1 and changed this setting "state:storeInSessionStorage" to true in Settings --> Advanced tab. And any number of boolean clause works fine.

Please remember to change elasticsearch.yml, index.query.bool.max_clause_count according to your needs.

CPU usage does drastically increase when a large query is executed, so be mindful of that.

Thanks,
Arun


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.