Error when setting default index in Kibana 5.1


(Stephen Goodall) #1

Hi,
I've recently taken a snapshot from a 2.3 cluster and restored it to a 5.1 cluster. (The AWS hosted service version :frowning: )

When I go to Kibana and make a new index pattern it lets me, but if I try to set any index as the default one I get this error:
Config: Error 400 Bad Request: [mapper_parsing_exception] failed to find type parsed [multi_field] for [defaultIndex]

Could this be due to .kibana having string and multi-field in the mappings?
{ ".kibana": { "mappings": { "index-pattern": { "_all": { "enabled": true }, "dynamic_templates": [ { "string_fields": { "match": "*", "match_mapping_type": "string", "mapping": { "fields": { "{name}": { "index": "analyzed", "omit_norms": true, "type": "string" }, "raw": { "ignore_above": 256, "index": "not_analyzed", "type": "string" } }, "type": "multi_field" } } } ], "properties": { "@version": { "type": "keyword" }, "fieldFormatMap": { "type": "text" }, "fields": { "type": "text" }, "intervalName": { "type": "text" }, "notExpandable": { "type": "boolean" }, "sourceFilters": { "type": "text" }, "timeFieldName": { "type": "text" }, "title": { "type": "text" } } }, "_default_": { "_all": { "enabled": true }, "dynamic_templates": [ { "string_fields": { "match": "*", "match_mapping_type": "string", "mapping": { "fields": { "{name}": { "index": "analyzed", "omit_norms": true, "type": "string" }, "raw": { "ignore_above": 256, "index": "not_analyzed", "type": "string" } }, "type": "multi_field" } } } ], "properties": { "@version": { "type": "keyword" } } }, "server": { "_all": { "enabled": true }, "dynamic_templates": [ { "string_fields": { "match": "*", "match_mapping_type": "string", "mapping": { "fields": { "{name}": { "index": "analyzed", "omit_norms": true, "type": "string" }, "raw": { "ignore_above": 256, "index": "not_analyzed", "type": "string" } }, "type": "multi_field" } } } ], "properties": { "@version": { "type": "keyword" }, "uuid": { "type": "keyword" } } }, "config": { "_all": { "enabled": true }, "dynamic_templates": [ { "string_fields": { "match": "*", "match_mapping_type": "string", "mapping": { "fields": { "{name}": { "index": "analyzed", "omit_norms": true, "type": "string" }, "raw": { "ignore_above": 256, "index": "not_analyzed", "type": "string" } }, "type": "multi_field" } } } ], "properties": { "@version": { "type": "keyword" }, "buildNum": { "type": "keyword" } } } } } }

I've tried deleting the .kibana index but when it gets rebuilt it seems to get the same mappings, do I need to override them somehow?

Thanks!


(Tyler Smalley) #2

Deleting the index also removes the mapping. What version of Kibana are you running?


(Stephen Goodall) #3

Hi Tyler ,
It's Version: 5.1.1
Could it be something to do with restoring the snapshot, as that will have included the .kibana index from version 4?
Thanks :slight_smile:


(Stephen Goodall) #4

I just deleted _template/* and deleted .kibana and now it works, I think my "default" template must have multi field in it. I'll look into converting that to an ES 5.1 equivalent, using fields I think?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.