Failed to Authenticate User after Installing X-Pack


(Ong) #1

I installed elasticsearch, kibana and x-pack all with version 6.2.2. I followed the steps described in the official documentation at Install X-pack on Elasticsearch

There were no errors along the way.

The problem came when I tried to set up passwords for the built in users like elastic and kibana. When I ran the "setup-passwords interactive" command, there was a message:

Connection failure to: http://10.1.2.3:9200/_xpack/security/user/kibana/_password?pretty
failed: Read timed out ERROR: Failed to set password for user kibana

The same error message appeared when I ran the "setup-passwords auto" command.

I am not sure if there is even the elastic and kibana users created because when I ran the command:

curl -u my_admin -XGET http://10.1.2.3:9200/_xpack/security/users

the output was an empty json. (my_admin is a user which was created using the users batch file in the bin\x-pack folder. This user has a superuser role)

Currently, I am not able to log into Kibana as well. The login page is disabled with the message "Login is currently disabled. Administrators should consult the Kibana logs for more details".

What should I do to correct this users problem?


(Josh Speer) #2

I have no help for you, but I'm having the same issue with 6.2.1 at the moment. If/when I get an answer.


(Tim Vernum) #3

It is likely that this is caused by some sort of underlying cluster problem and has nothing specific to do with the setup-passwords process.

Since you have security enabled, and haven't yet set a password for the builtin users, it can be tricky to diagnose the cluster health issues (but there a couple of options for that if you need).

The easiest first step is to check the elasticsearch logs. The location of the logs directory can vary depending on how you installed Elasticsearch (OS package, vs zip/tgz) and any configuration changes you've made. Locate the elasticsearch.log file within your logs directory, and check for any error messages.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.