X-pack kibana user fails to login

Hello,

I run the command elasticsearch-setup-passwords interactive and everything run smoothly.

But when I am trying to login at kibana with kibana user it fails I get the below error

{"statusCode":403,"error":"Forbidden","message":"Forbidden"}

With elastic user/password there is no issue. I created also a new user and I managed to login. I changed the password for kibana user and it still the same.

the node is only for kibana connected to a cluster. In general kibana works ok

node.master: false
node.data: false
node.ingest: false

Also when I run the curl 'localhost:9200/_cat/indices?v'?

I get

{"error":{"root_cause":[{"type":"security_exception","reason":"missing authentication credentials for REST request [/_cat/indices?v?]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}}],"type":"security_exception","reason":"missing authentication credentials for REST request [/_cat/indices?v?]","header":{"WWW-Authenticate":"Basic realm=\"security\" charset=\"UTF-8\""}},"status":401}

Any advice would be great full. Thank you

Hi @manosmustang,

You're not supposed to log in with kibana user, it's user that is used by Kibana internally to communicate with Elasticsearch. You need to log in with elastic user and create another user with the necessary roles and privileges.

Best,
Oleg