Failed to process file when import a dashboard file into kibana

When I import a dashboard.ndjson file from kibana 7.5.1 to kibana 7.4.1, it failed with error "the file could not be processed"

Then I tried call import api in kibana dev tool console, there's mapper parsing exception in response. Is there anyway to solve this import error?

Welcome to our community! :smiley:

I am not 100% sure that you can read a file in via the Console like that, have you tried to import the file directly via the UI?

Please note that both of those are well past EOL and no longer supported. You should upgrade ASAP.

As Saved Objects | Kibana Guide [7.15] | Elastic says;

Exported saved objects are not backwards compatible and cannot be imported into an older version of Kibana.

I tried import via UI and it has error "could not process the file" error. Is that because the dashboard cannot be imported to an older version?

Yes, the limitation still stands.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.