Filters not working when used in actions yaml file, but it works when using the command line filters options

Kibana Version: 7.15
Curator Version: 5.8.4

Hi, I'm working on creating an action file I can use with curator to delete Kibana indices older than 30 days from creation date. I wrote the following action file, however, when I tried using it, it didn't quite worked, it would only find 1 or 2 files for deletion:

    action: delete_indices
    description: >-
      Delete indices older than 30 days
      ignore_empty_list: True
      continue_if_exception: False
      disable_action: False
    - filtertype: pattern
      kind: regex
      value: '^(auditbeat-|apm-|filebeat-|metricbeat-|test-filebeat-)*'
    - filtertype: age
      source: creation_date
      direction: older
      unit: days
      unit_count: 30

After researching on the web I decided to try using the command line filters_list options, and this time it work as expected. Here is I had to do from the command line:

curator-home-here.../curator_cli $mode --config curator/config_file.yml delete-indices --filter_list '[{"filtertype":"pattern","kind":"prefix","value":"filebeat-"}, {"filtertype":"age","source":"creation_date","direction":"older","unit":"days","unit_count":30}]'

Before switching to using the command line, I played with the filtertype:pattern quite a bit because I thought that's what the problem stemmed from, but it didn't matter what I did, I could not make the action file did work as I was hoping.

I was wondering if anybody had come across this issue before, and knows a way to use the action file effectively.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.