"Fit Data Bounds" neglects filter settings


(Dennis) #1

Dear sir/madam,

We use ElasticCloud with ElasticSearch v6.4.0 and Kibana v6.4.0 (windows 10, google chrome)

Recently we updated our elastic cloud to version 6.4.0. In our dashboards we use the "coordinate map" several times and we make use of filters. When I selected certain data by filtering and than press the button "Fit Data Bounds" in a related coordinate map, it is not zooming to my selected data, while in version 6.3.0 this was working fine.
When I open the exact same coordinate map in "visualise" the "Fit Data Bounds" button is working fine (with the exact same data). This is true for several "coordinate maps".

So it seems that there is a minor bug in the execution of "Fit Data Bounds" button in the "dashboard" environment in version 6.4.0.

Can this issue be solved? I look forward hearing from you.

Steps to reproduce:

  1. load data with geo info
  2. show data in coordinate map
  3. use "fit data bounds" to zoom in at the data (for example after using a filter)

Expected behavior:
Zooming at the location of the data

  • works in the "visualise" environment where the coordinate map is developed
  • does not work in the "dashboard" where the coordinate map is exploited

Screenshots (if relevant):
From "visualise" environment:

From dashboard environment (with exact same data and filter settings as far as i can see):

also posted here in github/elastic/kibana


(kulkarni) #2

Hello

Thanks for posting also on github. The issue has been pinged to the internal GIS team. Awaiting an answer.

@thomasneirynck

Thanks
Rashmi


(Dennis) #3

Dear Rashmi, Thomas or somebody else,

Is somebody working on this issue? Or does someone have a glue what can be the problem? Look forward hearing from someone.

With kind regards, Dennis


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.