Fleet Server Status Inconsistency

Hi, I'm setting up Fleet in my production environment.

I've followed this guide Encrypt traffic in a self-managed cluster | Fleet User Guide [7.14] | Elastic

and I was able to enroll the Fleet Server. But something strange is happening.

The Fleet Server appears both as Offline and healthy

I see not errors from the EA Side and I'm recieving logs... How can I troubleshoot this situation?

I also notice in the last activity column that is always 5 minutes.

Thank you!
Regards
Ana

PD: I'm running version 7.14.1 for all components

I've enrolled one more agent and now I have..

Inspecting the fleet's internal indices, I see that the status is online and is regullary checked
I do not know why is not displaying properly the status in the UI

@nchaulet Any ideas on why this is not lining up?

Thank you @blaker
Just one more data (I don't know if is relevant), just in case:
The installation that is presenting the problem was done via RPM.
I made another installation using the zipped binaries and I observed some difference in the behaviour when enroll/install de fleet server

  1. When enrolling the elastic-agent with the Default Fleet Server Policy (rpm installation), it does all the tasks, it enrolls and the it stops. (In Kibana the status appears as updating but the EA is down)
    Then I have to start the agent using systemctl start elastic-agent

  2. When installing the elastic-agent the Default Fleet Server Policy (zipped binary installation) it does all the tasks, it enrolls and the agent remains running. In the Fleet UI appears first as Updating and then as Healthy

Regards
Ana

Hi @blaker does exists any way to reset all my fleet configuration (deleting indices or something) and try to install the fleet server again?
(I tried unenrolling and enrolling again but same result)
Thank you

Finally I managed to reset all my fleet configurations.
I've installed the fleet server again (using the ziped binary method) and the result is the same.

I solve it cleanning up this indices (that took me to the initial state)

.fleet-agents-7
.fleet-enrollment-api-keys-7
.fleet-policies-7
.fleet-actions-7
.fleet-servers-7
.fleet-policies-leader-7

Then I follow the same instructions I did before Encrypt traffic in a self-managed cluster | Fleet User Guide [7.14] | Elastic and this time worked