Free license import issue for ELK in version 5.6.2 with xpack freeshly installed,


#1

Hello,
after installing xpack i can't apply my license because I have this issue (I have no connection to internet from my Windows 2008 R2 server ) :

...
d+AA","start_date_in_millis":1507248000000}}
Enter host password for user 'elastic':
Enter host password for user 'tFormat':
_ % Total % Received % Xferd Average Speed Time Time Time Current_
_ Dload Upload Total Spent Left Speed_
107 430 103 415 0 15 13387 483 --:--:-- --:--:-- --:--:-- 12903
curl: (6) Could not resolve host: XAAiAGwAaQBjAGUAbgBzAGUAXAAiADoAewBcACIAdQBpAGQAXAAiADoAXAAiADM
cAMQBiAGMALQA0ADEAYQA5AC0AOAA1AGYAYQAtADMAZAAyADIANQA5AGEAZQA1AGUAOQBjAFwAIgAsAFwAIgB0AHkAcABlAFw
MAXAAiACwAXAAiAGkAcwBzAHU
curl: (6) Could not resolve host: xml; Host not found
curl: (6) Could not resolve host: text; Host not found

I don't know this strange tformat user ! and have not its password too (by default i took changeme in doubt !)

i have fine update kibana,elastic, logstash passwords previously . i can connect to 9200 port by Http (+password) , for example

{
_ "license" : {_
_ "status" : "active",_
_ "uid" : "1d72a87e-844e-4d15-b7a3-a8b1cfbcd224",_
_ "type" : "trial",_
_ "issue_date" : "2017-10-06T15:07:33.121Z",_
_ "issue_date_in_millis" : 1507302453121,_
_ "expiry_date" : "2017-11-05T15:07:33.121Z",_
_ "expiry_date_in_millis" : 1509894453121,_
_ "max_nodes" : 1000,_
_ "issued_to" : "elasticsearch",_
_ "issuer" : "elasticsearch",_
_ "start_date_in_millis" : -1_
_ }_
}

If i launch curl in verbose mode i can see an 401 error code but after ignoring this (?) :

Enter host password for user 'elastic':
Enter host password for user 'tFormat':
* Couldn't find host 127.0.0.1 in the netrc file; using defaults
* About to connect() to 127.0.0.1 port 9200 (#0)
* Trying 127.0.0.1... connected
* Connected to 127.0.0.1 (127.0.0.1) port 9200 (#0)
* Server auth using Basic with user 'tFormat'
> PUT /xpack/license HTTP/1.1
> Authorization: Basic dEZvcm1hdDplbGFzdGljcGFzc3dvcmQ=
> User-Agent: curl/7.19.2 (i386-pc-win32) libcurl/7.19.2 OpenSSL/0.9.8i zlib/1.2.3
> Host:127.0.0.1:9200
> Accept: /
> Content-Type: application/json
> Content-Length: 15
>
} [data not shown]
_ % Total % Received % Xferd Average Speed Time Time Time Current

_ Dload Upload Total Spent Left Speed

_ 0 15 0 0 0 15 0 319 --:--:-- --:--:-- --:--:-- 319< HTTP/1.1 401 Unauthorized_
*** Authentication problem. Ignoring this.**
< WWW-Authenticate: Basic realm="security" charset="UTF-8"
< content-type: application/json; charset=UTF-8
< content-length: 415
<
{ [data not shown]
107 430 103 415 0 15 4414 159 --:--:-- --:--:-- --:--:-- 8510* Connection #0 to host 127.0.0.1 left int
act

i did not see other similar solved topics, could you please help me ?


(Mark Walkom) #2

Please show the complete curl command you are running.


#3

the complete command is (i have protected the double quote by \ for the data string due to windows ) :

curl -XPUT -u elastic 'http://127.0.0.1:9200/_xpack/license' -H "Content-Type: application/json" -d {"license":{"uid":"3def8f53-71bc-41a9-85fa-3d2259ae5e9c","type":"basic","issue_date_in_millis":1507248000000,"expiry_date_in_millis":1538870399999,"max_nodes":100,"issued_to":"jerome azais (Spie)","issuer":"Web Form","signature":"AAAAAwAAAA2v8bCJrr9YyYiqV3dJAAABmC9ZN0hjZDBGYnVyRXpCOW5Bb3FjZDAxOWpSbTVoMVZwUzRxVk1PSmkxaktJRVl5MUYvUWh3bHZVUTllbXNPbzBUemtnbWpBbmlWRmRZb25KNFlBR2x0TXc2K2p1Y1VtMG1UQU9TRGZVSGRwaEJGUjE3bXd3LzRqZ05iLzRteWFNekdxRGpIYlFwYkJiNUs0U1hTVlJKNVlXekMrSlVUdFIvV0FNeWdOYnlESDc3MWhlY3hSQmdKSjJ2ZTcvYlBFOHhPQlV3ZHdDQ0tHcG5uOElCaDJ4K1hob29xSG85N0kvTWV3THhlQk9NL01VMFRjNDZpZEVXeUtUMXIyMlIveFpJUkk2WUdveEZaME9XWitGUi9WNTZVQW1FMG1DenhZU0ZmeXlZakVEMjZFT2NvOWxpZGlqVmlHNC8rWVVUYzMwRGVySHpIdURzKzFiRDl4TmM1TUp2VTBOUlJZUlAyV0ZVL2kvVk10L0NsbXNFYVZwT3NSU082dFNNa2prQ0ZsclZ4NTltbU1CVE5lR09Bck93V2J1Y3c9PQAAAQBa6pNYYROrzllaHs3Gwv1TKy2dodewQKyJh0NtmclC+IkFW1psDfte+YCtNv8d2zbAbRnQPGMcHbIX5626Z7UAYsPTJ2URFunZ2koHgByrg27sEx0I7hY3p8FCXNEtlQL9/qsdU95r/qQ28ZrtbpzCKHYGVO4dsxqHLJZ2kn51tBJTuUxG1X8X9BbWyYGpvDkyOlH8dQv9URdZWg5RszW4PXxgjp5u1Js63aEhijsbm9vedKM9iOiqV4H1gtKSJgyFogEJa7jiT+GbEoEbeRp4/9WJTLF191o2M4sc9wi03yuGwtli9xXyyMnby7XAupSGRg49BnXSF/i9wZ66d+AA","start_date_in_millis":1507248000000}}


#4

you can't see the double quote (to protect my data string after the -d option) in my previous command because this editor remove them. my command (i am under windows ) is :

curl -XPUT -u elastic 'http://127.0.0.1:9200/_xpack/license' -H "Content-Type: application/json" -d { license\":{\"uid\":\"3def8f53-71bc-41a9-85fa-3d2259ae5e9c\",\"type\":\"basic\",\"issue_date_in_millis\":1507248000000,\"expiry_date_in_millis\":1538870399999,\"max_nodes\":100,\"issued_to\":\"jerome azais (Spie)\",\"issuer\":\"Web Form\",\"signature\":\"AAAAAwAAAA2v8bCJrr9YyYiqV3dJAAABmC9ZN0hjZDBGYnVyRXpCOW5Bb3FjZDAxOWpSbTVoMVZwUzRxVk1PSmkxaktJRVl5MUYvUWh3bHZVUTllbXNPbzBUemtnbWpBbmlWRmRZb25KNFlBR2x0TXc2K2p1Y1VtMG1UQU9TRGZVSGRwaEJGUjE3bXd3LzRqZ05iLzRteWFNekdxRGpIYlFwYkJiNUs0U1hTVlJKNVlXekMrSlVUdFIvV0FNeWdOYnlESDc3MWhlY3hSQmdKSjJ2ZTcvYlBFOHhPQlV3ZHdDQ0tHcG5uOElCaDJ4K1hob29xSG85N0kvTWV3THhlQk9NL01VMFRjNDZpZEVXeUtUMXIyMlIveFpJUkk2WUdveEZaME9XWitGUi9WNTZVQW1FMG1DenhZU0ZmeXlZakVEMjZFT2NvOWxpZGlqVmlHNC8rWVVUYzMwRGVySHpIdURzKzFiRDl4TmM1TUp2VTBOUlJZUlAyV0ZVL2kvVk10L0NsbXNFYVZwT3NSU082dFNNa2prQ0ZsclZ4NTltbU1CVE5lR09Bck93V2J1Y3c9PQAAAQBa6pNYYROrzllaHs3Gwv1TKy2dodewQKyJh0NtmclC+IkFW1psDfte+YCtNv8d2zbAbRnQPGMcHbIX5626Z7UAYsPTJ2URFunZ2koHgByrg27sEx0I7hY3p8FCXNEtlQL9/qsdU95r/qQ28ZrtbpzCKHYGVO4dsxqHLJZ2kn51tBJTuUxG1X8X9BbWyYGpvDkyOlH8dQv9URdZWg5RszW4PXxgjp5u1Js63aEhijsbm9vedKM9iOiqV4H1gtKSJgyFogEJa7jiT+GbEoEbeRp4/9WJTLF191o2M4sc9wi03yuGwtli9xXyyMnby7XAupSGRg49BnXSF/i9wZ66d+AA\",\"start_date_in_millis\":1507248000000}}


#5

it's okay no, in fact the tformat is due to powershell itself, with cmd interpreter i have not the tformat issue.

i need to change simple quotes by double quotes inside the provide command (in elastic guide line https://www.elastic.co/guide/en/x-pack/5.6/installing-license.html ) like that :

curl -XPUT -u elastic "http://127.0.0.1:9200/_xpack/license" -H "Content-Type: application/json" -d @<my_file>

i have not powsershell in version number 3 that is the reason i have not used the get-content command for windows because Invoke-WebRequest is missing in powershell 2.

to conclude my previous command is running fine under cmd(dos) interpreter instead of use powershell

So this topics can be solved , thanks a lot Mark for your help


(Mark Walkom) #6

Next time it's good to use </> to code format things, that way it won't remove anything :slight_smile:


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.