Getting"Timeout" error while making kibana to work with SearchGuard


(balaji) #1
      Hi Everyone

I Have Implemented “search-guard” Elasticsearch

-->

First i have created a “SearchGuard” Index

*Then I have Installed and Configured it in logging.yml and Elasticsearch.yml

*In elasticsearch.yml i have given a user name:admin and password:admin

note:I have given all permissions to admin user in “searchguard” index

*HERE is my index

curl -XPUT 'http://localhost:9200/searchguard/ac/ac' -d '{

"acl": [

{


    "Comment": "By default no filters are executed 

and no filters a by-passed. In such a case an exception is thrown and
access will be denied.",

    "filters_bypass": [],

    "filters_execute": []

 },

 {

       "Comment": "For role admin all filters are bypassed (so none will be executed). This means unrestricted access.",

       "roles": [

           "admin"

       ],

       "filters_bypass": [],

       "filters_execute": [“actionrequestfilter.kibanaUser”]

 }

 ]

}'

*Here is my elasticsearch.yml

searchguard.enabled: true

searchguard.rewrite_get_as_search: true

searchguard.allow_all_from_loopback: true

searchguard.config_index_name: searchguard

searchguard.key_path: /var/lib/elasticsearch/searchguard_node.key

##User settings

searchguard.authentication.settingsdb.user.admin: admin

searchguard.actionrequestfilter.names: ["kibanaUser","admincopy"]

searchguard.actionrequestfilter.kibanaUser.allowed_actions:["indices:admin/get","indices:data/read/", "monitor"]

--->Here iam getting “timeout” Error.

As i am new to this concept.Not getting.Please someone help me out in this??

Thanks And Regards

Balaji


(Boaz Leskes) #2

Are you using Shield to secure your cluster or something else?


(balaji) #3

No i am using Search-guard elasticsearch. That previous issue is solved by adding the "searchguard.allow_all_from_loopback: true" attribute to the elasticsearch.yml file ....But Now unable to use search-guard with kibana. I have edited the above Issue ...Can u please see that and Help me out

Thanks and Regards
Balaji


(Boaz Leskes) #4

oh, I see. I don't know Search guard. Sorry.


(Mohanrao) #5

Just want to check did you added the username and password in the kibana settings?


(balaji) #6

yes.Actually i didt map that user to the elasticsearch.yml. now after mapping the issue is solved.

But kibana is not accepting this default configuration
"filters_bypass": [],
"filters_execute": []

so when i change the above code getting internal server error


(system) #7