Getting warning in for every Kibana Field

Hi Experts,

I have created index using logstash and stored it to ES. Now when I feed it to kibana I am getting following warning for every field.

"Doc Values are not enabled on this field . This may lead to excess heap consumption when visualizing"

Please suggest what needs to be done here


Take a look here -

Thanks Mark,

I read this document and got some idea what could be the reason behind . It says to enable Doc value I have to use following
PUT /music/_mapping/song
"properties" : {
"tag": {
"type": "string",
"index" : "not_analyzed",
"doc_values": true

My question is where do I need to paste this code. Sorry , I am new to this . Do I need to save it in "elasticsearch-template.json" under template folder in ES.

Please suggest.

That is Sense code, if you are using Marvel you can find Sense under the dashboards tab.

Otherwise you can just append curl -X to this and just use curl to send it to ES. You will need to single quote the json though!