Grafana can't see ES indexes

Hi all!

Just started using Grafana + ES. I run ES in docker:

docker run -d --name es -p 9200:9200 -p 9300:9300 -e "discovery.type=single-node"

Then generated some data into index recipes that look like these:

"hits": [
"_index": "recipes",
"_type": "salads",
"_id": "8d_JKHIBzym3yKfai79o",
"_score": 1,
"_source": {
"title": "-",
"submitter": "-",
"description": "-",
"calories": 0,
"ingredients": ,
"timestamp": 1589822195829

Then I registered created ES cluster in GRafana:

"datasource": {
"id": 4,
"orgId": 1,
"name": "Elasticsearch",
"type": "elasticsearch",
"typeLogoUrl": "",
"access": "direct",
"url": "http://localhost:9200",
"password": "",
"user": "",
"database": "recipes",
"basicAuth": false,
"basicAuthUser": "",
"basicAuthPassword": "",
"withCredentials": false,
"isDefault": true,
"jsonData": {
"esVersion": 77,
"logLevelField": "",
"logMessageField": "",
"maxConcurrentShardRequests": 256,
"timeField": "timestamp"
"secureJsonFields": {},
"version": 25,
"readOnly": false
"id": 4,
"message": "Datasource updated",
"name": "Elasticsearch"

Started a panel. After that I expected to see data that were in recipe index but I didn't.
They must appear in panel, right?

In dev tools console I see only OPTION http requests:

I'm trying to work out this issue all day long and this upsets me.

Have you tried raising this on a grafana forum? I am not sure we have the knowledge to be able to troubleshoot this problem sorry.

Oh, you're right! My mistake. I was going to write this message in Grafana community.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.