Having issues setting up MetricBeat with cloud


(Michael Duffy) #1

Hi Folks;

I'm trying to deploy Metricbeats onto a Windows host - this will then talk to our ElasticCloud account. Right now my elastic.yml looks like this:

metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false
setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

tags: ["development", "windows"]

setup.kibana:
  cloud_id: <snip>"
  cloud_auth: "<snip"

output.elasticsearch:
  hosts: ["localhost:9200"]

However, I'm not seeing Metrics arrive on the cloud. When I start in on the command line (Simply with a metricbeat.exe) I get the following error:

2018-05-16T12:02:50.883+0100	ERROR	pipeline/output.go:74	Failed to connect: Get http://localhost:9200: dial tcp 127.0.0.1:9200: connectex: No connection could be made because the target machine actively refused it.

Any ideas where I'm going wrong? I'd assume that by supplying the cloud credentials in the config it'd override the output, and that's certainly the case on my Linux hosts..

Cheers;

Mike


(Andrew Kroh) #2

Based on the example show here I think your config should look like this:

metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false
setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression
  #_source.enabled: false

tags: ["development", "windows"]

cloud.id: "blah"
cloud.auth: "elastic:YOUR_PASSWORD"

(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.