Help with Fleet setup

I got a fleet server to connect to my sandbox cluster to test and setup this framework. I am trying to get an agent to connect with my fleet server. I am trying to just get the quickstart going so useing the --insecure flag.

Fleet and agent running on Ubuntu.

Using the command from agent box of : sudo elastic-agent enroll --url=http://fqdn:8220 --enrollment-token=token --insecure

the command runs and I get a repeated:
{"log.level":"info","@timestamp":"2022-03-15T10:35:37.185-0500","log.origin":{"":"cmd/enroll_cmd.go","file.line":474},"message":"Retrying enrollment to URL: http://fqdn of fleet server:8220/","ecs.version":"1.6.0"}

Any help or assistance. Is there a way to ping the endpoint to see if its listening?

here is the pertinent part.

"Remote server is not ready to accept connections, will retry in a moment.","ecs.version":"1.6.0"}

Have you tried troubleshooting the url to see if you gat a healthy status from the fleet api ?

I actually found that the fleet server was not listening on the correct port. I had to enable the port and problem solved.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.