How Can I configure for another ES cluster?


(Allie Yang Yang) #1

I am trying to use the data from another totally different ES cluster through Kibana.
I already changed Kibana URL in its yml. For ES, how should I configure it to not go to the default 127.0.01?

Below is my current ES yml with new port/host. What else shall I do to make it listen to new port/host?

---------------------------------- Network -----------------------------------

Set the bind address to a specific IP (IPv4 or IPv6):

network.host: 192.168.0.194

Set a custom port for HTTP:

http.port: 9300

For more information, see the documentation at:

http://www.elastic.co/guide/en/elasticsearch/reference/current/modules-network.html

--------------------------------- Discovery ----------------------------------

Pass an initial list of hosts to perform discovery when new node is started:

The default list of hosts is ["192.168.0.194"]

discovery.zen.ping.unicast.hosts: ["192.168.0.238","192.168.0.237","192.168.0.208","192.168.0.181"]


(Mark Walkom) #2

You already have;


(Allie Yang Yang) #3

I keep see below error:

Exception in thread "main" BindTransportException[Failed to bind to [9300-9400]]; nested: ChannelException[Failed to bind to: /192.168.0.194:9400]; nested: BindException[Can't assign requested address];
Likely root cause: java.net.BindException: Can't assign requested address
at sun.nio.ch.Net.bind0(Native Method)
at sun.nio.ch.Net.bind(Net.java:433)
at sun.nio.ch.Net.bind(Net.java:425)
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)
at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
at org.jboss.netty.channel.socket.nio.NioServerBoss$RegisterTask.run(NioServerBoss.java:193)
at org.jboss.netty.channel.socket.nio.AbstractNioSelector.processTaskQueue(AbstractNioSelector.java:391)
at org.jboss.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:315)
at org.jboss.netty.channel.socket.nio.NioServerBoss.run(NioServerBoss.java:42)
at org.jboss.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
at org.jboss.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)


(Mark Walkom) #4

Why did you change this? You should leave it at 9200.


(Allie Yang Yang) #5

Changed it back to 9200 but still the same error...


(Mark Walkom) #6

Does that address exist on the host?


(Allie Yang Yang) #7

I retrieved from below when i do: curl {server address}/_nodes/_local.
I can choose any address from unicast, right?

curl https://rd-search.ew1.dev.aws.adobestock.com/_nodes/_local
{"cluster_name":"elasticsearch-stock-aws","nodes":{"wdFkfeoeT7KHwM_I08Bweg":{"name":"aws-elasticsearch-2","transport_address":"inet[ip-192-168-0-208.eu-west-1.compute.internal/192.168.0.208:9300]","host":"ip-192-168-0-208","ip":"192.168.0.208","version":"1.7.5","build":"00f95f4","http_address":"inet[/192.168.0.208:8080]","attributes":{"master":"true"},"settings":{"cluster":{"name":"elasticsearch-stock-aws"},"index":{"search":{"slowlog":{"threshold":{"query":{"warn":"10s","trace":"500ms","debug":"2s","info":"5s"},"fetch":{"warn":"1s","trace":"200ms","debug":"500ms","info":"800ms"}}}},"indexing":{"slowlog":{"threshold":{"index":{"warn":"10s","trace":"500ms","debug":"2s","info":"5s"}}}},"number_of_shards":"32","number_of_replicas":"2","similarity":{"default":{"type":"custom_fotolia"}}},"foreground":"yes","transport":{"tcp":{"compress":"true"}},"pqcode_plugin":{"encoder_blob_path":"config/pq-encoder/stock2.encoder"},"bootstrap":{"mlockall":"true"},"threadpool":{"bulk":{"queue_size":"1000"}},"cloud":{"aws":{"region":"eu-west-1"}},"path":{"conf":"/etc/elasticsearch/elasticsearch.yml","data":"/mnt/","logs":"/mnt/elastic_logs","work":"/mnt/","home":"/usr/share/elasticsearch"},"node":{"data":"true","name":"aws-elasticsearch-2","master":"true"},"plugin":{"mandatory":"cloud-aws"},"discovery":{"type":"ec2","ec2":{"groups":"elasticsearch"},"zen":{"ping":{"multicast":{"enabled":"false"},"unicast":{"hosts":["192.168.0.238","192.168.0.237","192.168.0.194","192.168.0.181"]}}}},"name":"aws-elasticsearch-2","http":{"compression":"true","port":"8080","cors":{"enabled":"true","allow-origin":"*"}},"client":{"type":"node"},"config":{"ignore_system_properties":"true"}},"os":{"refresh_interval_in_millis":1000,"available_processors":8,"cpu":{"vendor":"Intel","model":"Xeon","mhz":2400,"total_cores":8,"total_sockets":1,"cores_per_socket":8,"cache_size_in_bytes":30720},"mem":{"total_in_bytes":33738887168},"swap":{"total_in_bytes":0}},"process":{"refresh_interval_in_millis":1000,"id":1331,"max_file_descriptors":64000,"mlockall":true},"jam"...


(Mark Walkom) #8

Are those IPs bound to the host you are trying to start ES on?


(Allie Yang Yang) #9

right.
The server address there (I curled with) is the new ES server i try to get on.

Could it be the ES server is already on so it prevents duplicate start?


(system) #10