How Can I use Kibana to see indices in another ES Cluster?


(Allie Yang Yang) #1

I am trying to see data from a totally different ES Cluster set up by others. How Could see them in Kibana?

Shall I change the elasticsearch.url in the kibana.yml file and fill it with the new Cluster's server address?

Should I also change the IP and Host in elasticsearch.yml?


(Matt Bargar) #2

elasticsearch.url should include the host, port, and protocol, e.g. http://localhost:9200

Note however that you won't be able to see any of your existing index patterns or saved objects when you switch clusters. All of that information is stored in the cluster Kibana is pointing to.


(Allie Yang Yang) #3

Below is the new cluster's address i want to connect to, should i have elasticsearch.url as inet[ip-192-168-0-194.eu-west-1.compute.internal/192.168.0.194:9300]?

"cluster_name":"elasticsearch-stock-aws","nodes":{"MDJh1n6tQbqNTXOBbhVFow":{"name":"aws-elasticsearch-3","transport_address":"inet[ip-192-168-0-194.eu-west-1.compute.internal/192.168.0.194:9300]","host":"ip-192-168-0-194","ip":"192.168.0.194","version":"1.7.5","build":"00f95f4","http_address":"inet[/192.168.0.194:8080]","attributes":{"master":"true"},"settings":{"cluster":{"name":"elasticsearch-stock-aws"},"index":{"number_of_shards":"32","number_of_replicas":"2","similarity":{"default":{"type":"custom_fotolia"}}},"foreground":"yes","transport":{"tcp":{"compress":"true"}},"pqcode_plugin":{"encoder_blob_path":"config/pq-encoder/stock2.encoder"},"bootstrap":{"mlockall":"true"},"threadpool":{"bulk":{"queue_size":"1000"}},"cloud":{"aws":{"region":"eu-west-1"}},"path":{"conf":"/etc/elasticsearch/elasticsearch.yml","data":"/mnt/","logs":"/usr/share/elasticsearch/logs","work":"/mnt/","home":"/usr/share/elasticsearch"},"node":{"data":"true","name":"aws-elasticsearch-3","master":"true"},"discovery":.....

Then I kept get the error message:
[warning][elasticsearch] Unable to revive connection: http://localhost:9200/


(Allie Yang Yang) #4

Shall I change anything in elasticsearch.yml?


(Matt Bargar) #5

Most likely you just want to set elasticsearch.url to 192.168.0.194:9300 or ip-192-168-0-194.eu-west-1.compute.internal:9300. Elasticsearch needs to bind to whatever public address you're trying to connect to, so yes you'll need to update elasticsearch.yml if you haven't already.


(Allie Yang Yang) #6

Is below right?
ES still tries to connect 127.0.0.1...

I changed elasticsearch.yml in network portion:

---------------------------------- Network -----------------------------------

Set the bind address to a specific IP (IPv4 or IPv6):

network.host: 192.168.0.194

Set a custom port for HTTP:

http.port: 9300

As well as Discover portion:

--------------------------------- Discovery ----------------------------------

Pass an initial list of hosts to perform discovery when new node is started:

The default list of hosts is ["192.168.0.194"]

discovery.zen.ping.multicast.enabled: false

discovery.zen.ping.unicast.hosts: ["192.168.0.238","192.168.0.237","192.168.0.208","192.168.0.181"]


(Matt Bargar) #7

Looks ok to me. You might want to ask in the Elasticsearch forum. Once Elasticsearch is accessible on a non-loopback address it should be easy to connect Kibana.


(Allie Yang Yang) #8

Ok, last question, these changes in elasticsearch.yml are all in comments....DO they really work?


(Matt Bargar) #9

You'll definitely need to uncomment any lines you want to make active.


(Allie Yang Yang) #10

i solved it. It is version compatible between Kibana and ES.


Kibana Error to connect to another server
(system) #11