Unable to see my data in the Kibana


(Sharon Sasporta) #1

I have lot of data in the elasticsearch. I can see my index via the elasticsearch-head plugin, but I am not able to see that in the kibana.

Maybe the kibana isn't connecting to my elasticsearch, or elastic search doesn't listen to the same port request.

I don't know what the problem is.

elasticsearch.yml:
network.host: 0.0.0.0
http.port: 9200

kibana.yml:
server.host: "0.0.0.0"
elasticsearch.url: "http://0.0.0.0:9200"

Regards,
Sharon.


#2

Hi, thanks for posing out. Let;s do some trouble shooting and see if it works.
First of all, would you mind checking if your kibana version matches to your elasticsearch.
Secondly, did you start all of them, elasticsearch and kibana both?
Then, can you visit localhost:9200, if show a json for you, then you are good with elasticsearch.
And then, visit localhost:5601, if you can see kibana. Then you need to go to setting and manage your index patterns.
For more information, anyway to show your screanshoot and we can probably look at the details. Thanks!


(Felix Stürmer) #3

Hi @ssasporta,

your hypothesis about Kibana not connecting to Elasticsearch might be correct. While 0.0.0.0 is a shorthand for "bind to all available network interfaces" in network.host and server.host, it is not a valid routable ip address for use in elasticsearch.url. Instead, that setting is required to contain a url with either a hostname that resolves to Elasticsearch's ip address or the ip address directly. If both processes are running on the same machine, setting it to http://localhost:9200 should work.


(Sharon Sasporta) #4

The current configuration is:
kibana.yml: elasticsearch.url: "http://localhost:9200"
elasticsearch.yml: network.host: 0.0.0.0

Installed versions:
kibana-4.6.1-1.x86_64 ,
elasticsearch-2.4.1-1.noarch

Status:

elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled)
Active: active (running) since Mon 2016-11-28 09:25:19 IST; 9s ago
mpswrk1@eaasrt!MPS:mpswrk1/ElasticSearch/scripts> kstatus
kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; disabled)
Active: active (running) since Mon 2016-11-28 09:25:32 IST; 10min ago

I can see the elastic via head plugin in address:

     http://10.235.81.127:9200/_plugin/head/

I can't see kibana in : http://localhost:5601/

But I can see kibana in :

http://10.235.81.127:5601/app/kibana#/settings/indices/?_g=(refreshInterval:(display:Off,pause:!f,value:0),time:(from:now-15m,mode:quick,to:now))

Thanks
Sharon.


(Felix Stürmer) #5

Looks like the server.host setting in the kibana configuration might not be applied correctly or localhost does not resolve correctly on the machine. What does ss -n -l -t -p | awk 'NR==1 || /kibana|5601/' show?


(Sharon Sasporta) #6

Hi,
Thanks for your answer.

Things were solved few days ago. It is not relevant anymore.

Regards,
Sharon.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.