How to create users in Kibana and enable role management in Kibana?

Continuing the discussion from Kibana Management missing Role Management:

We are using ELk Stack 6.5 and after activating trial X-PACK license, we still can't see Kibana Role Management.

  1. Checked the license status its active
  2. Enabled x-pack in elasticsearch.yml file, true

Note - I am using the default user created during installation for logging into Kibana.

After I enable the xpack security the default user created during installation stops working in Kibana. I tried creating users in elastic search using

bin/elasticsearch-users useradd <username> -p <password> -r kibana_user

But I am not able to login using this user in Kibana.

Please don't imply a connection where there is none. The original question mentioned Elasticsearch 6.1 , and you are running 6.5.3. Not all the questions in the last message of @Christian_Dahlqvist are relevant now as X-Pack is already included but :

Nor the Elastic Search security works

You will have to add some more information to this, as the "it does not work" is not enough for us to offer any meaningful suggestions.

1 Like

I have modified the post with more details. Yes I did check if the license is Active and the license is trial.

There is no specific default user created during installation in Elasticsearch. There are a number of built-in users but you first need to set their passwords in order to use them. Which user are you talking about ?

If you say "stops" working, then I am assuming it was working before? What was an indication that it worked before? Did you login with that user to Kibana via the login form?

Can you share some information on how you installed Elasticsearch (zip/tar archives ? .deb / .rpm ? docker? ) and what is your Operating System ?

Checked the license status its active

Can you share the output of the request to _xpack/license endpoint that you made?

Did you restart Elasticsearch after setting that ?

I have installed Elastic Search using deb packages following the instructions in this article,

I created a user for Kiabna using following command,

echo "kibanaadmin:openssl passwd -apr1" | sudo tee -a /etc/nginx/htpasswd.users

When I said it stops working I meant the user I created in the above step is not letting me login in Kibana.

Output of the license status,
{ "license" : { "status" : "active", "uid" : "9c1c5767-c31a-4dd9-b7f8-725251fe5049", "type" : "trial", "issue_date" : "2019-01-18T10:21:18.504Z", "issue_date_in_millis" : 1547806878504, "expiry_date" : "2019-02-17T10:21:18.504Z", "expiry_date_in_millis" : 1550398878504, "max_nodes" : 1000, "issued_to" : "elasticsearch", "issuer" : "elasticsearch", "start_date_in_millis" : -1 } }

I did restart Elastic Search after creating the user using elasticsearch-users command.

This document instructs you to use nginx in front of Kibana to authenticate the users. This might have been a valid option when you didn't have security enabled but there really is no reason for you to keep nginx. Kibana can handle the authentication itself.

As you can see from the command you entered, this is not a Kibana user, it is an nginx user.

My suggestion is to remove nginx and follow our documentation for configuring security for the Elastic stack

Also, can you please modify the title to something more helpful for other people viewing / answering in these forums? Your problem has very little to do with role management and the issue you linked to in the first post.


My original question was how do I see the user Management in Kibana? How do I see this screen?

Or is itonly available in Elastic Cloud Enterprise Edition?

It is also available in the on premises (non cloud) versions, assuming that security is enabled in Kibana and Elasticsearch.

What we have been trying to help you achieve in this thread is to enable security in Kibana and Elasticsearch. Please follow my suggestions from above

Thank you, I followed your instructions and now I am able to see User Management in Kibana and I could also create new users.

1 Like

Hi @aditya_kanekar

Me too facing the same problem as you had.

How you resolved ?

@Amitittech please don't hijack other people threads. It would be better if you open a new topic where you would post also some details about:

  • What version are you using?
  • What are you trying to do?
  • What have you done so far? Show us the relevant parts of your configuration.
  • What are you expecting to happen that doesn't , and what happens instead?
  • What are the error messages if any?
  • Are there any logs from elasticsearch to share?


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.