How to disable the monitoring completely?


(Vikrant Aggarwal) #1

I am using following docker-compose.yml file to disable the monitoring on ELK stack. I have removed the lines for kibana intentionally because kibana was crashing continuously if I add the monitoring parameter in it also.

version: '3'
services:
  elasticsearch:
    image: docker.elastic.co/elasticsearch/elasticsearch:6.2.4
    container_name: elasticsearch
    environment:
      - "discovery.type=single-node"
      - "xpack.security.enabled=false"
      - "XPACK_MONITORING_ENABLED=false"
    volumes:
      - esdata:/usr/share/elasticsearch/data:rw
    ports:
      - 9200:9200
    networks:
      - elk
    restart: unless-stopped
  kibana:
    depends_on:
    - elasticsearch
    image: docker.elastic.co/kibana/kibana:6.2.4
    networks:
      - elk
    ports:
      - 5601:5601
    restart: unless-stopped
  logstash:
    image: ervikrant06/logstashbpimage1:6.2.4
    depends_on:
      - elasticsearch
    networks:
      - elk
    environment:
      - "xpack.security.enabled=false"
      - "INPUT1=/var/tmp/log"
      - "XPACK_MONITORING_ENABLED=false"
    restart: unless-stopped
    volumes:
      - /tmp/logstash/:/var/tmp/log
volumes:
  esdata:
    driver: local
networks:
  elk:

Anyone knows how to disable the monitoring completely in ELK stack?


(David Pilato) #2

The easiest way is to use 6.3.0 which does not have monitoring on by default.

The setting name is xpack.monitoring.enabled otherwise.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.