How to disable x-pack security for tribe node?


(Yu Watanabe) #1

Hello.

I am trying to temporarily disable x-pack security setting on tribe node (es ver 5.4.0).
I have tried below 2 ways but neither of them succeeded.

Case 1. Setting x-pack.security.enable inside tribe definition

tribe:
on_conflict: prefer_dc1
  t1:
    cluster.name: dc1
    discovery.zen.ping.unicast.hosts: ["10.0.1.4","10.0.1.5"]
    xpack.security.enabled: false

I ended up with below error.

[2017-05-18T11:48:49,988][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [tribe] uncaught exception in thread [main] org.elasticsearch.bootstrap.StartupException:java.lang.IllegalStateException: tribe setting [tribe.t1.xpack.security.enabled] must be set to true but the value is [false]

Case 2. Setting x-pack.security.enable outside tribe definition

tribe:
  on_conflict: prefer_dc1
  t1:
    cluster.name: dc1
    discovery.zen.ping.unicast.hosts: ["10.0.1.4","10.0.1.5"]
    node.ml: false
    xpack.ml.enabled: false
node.ml: false
xpack.ml.enabled: false
tribe.t1.xpack.security.enabled: false

This ended up with node adding and removing back and forth.

[2017-05-18T12:13:31,991][INFO ][o.e.c.s.ClusterService   ] [uniform-1] added {{tribe/t1}{32OZnV0tQF6RjRW-Jayp9Q}{MPpnbzG4SvapKIRxqRkn8w}{10.0.1.7}{10.0.1.7:9301},}, reason: zen-disco-receive(from master [master {uniform-2}{-PGt5q_YRIGFQ4-xAJb6zw}{sevy7rL3T2-qLsf24A6Mhw}{10.0.1.5}{10.0.1.5:9300}{ml.enabled=true} committed version [103]])
[2017-05-18T12:13:32,035][INFO ][o.e.c.s.ClusterService   ] [uniform-1] removed {{tribe/t1}{32OZnV0tQF6RjRW-Jayp9Q}{MPpnbzG4SvapKIRxqRkn8w}{10.0.1.7}{10.0.1.7:9301},}, reason: zen-disco-receive(from master [master {uniform-2}{-PGt5q_YRIGFQ4-xAJb6zw}{sevy7rL3T2-qLsf24A6Mhw}{10.0.1.5}{10.0.1.5:9300}{ml.enabled=true} committed version [104]])

This reference worked with second case but not for me.

Is there any way to disable x-pack security on tribe node?


(Yu Watanabe) #2

Got it working. You need to set xpack.security.enabled : false inside the tribe node stanza as well. xpack option seems to be not inherited to the tribe setting.

node.master: false
node.data: false
node.ingest: false

tribe:
  t1:
    discovery.zen.ping.unicast.hosts: ["192.168.11.15"]
    xpack.security.enabled: false

xpack.security.enabled: false

(Bhavya R M) #3

Glad you got it working. Thanks for letting us know.

Cheers
Bhavya


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.