How to elude error [can't select channel size is 0 for types]?


(Yu Watanabe) #1

Hello.

I have came across below error while creating index pattern through kibana UI. I would appreciate if I could get some help to elude the error.

[2018-05-08T05:23:16,981][WARN ][r.suppressed             ] path: /.kibana/doc/index-pattern%3Ae9aaa8c0-527f-11e8-a6f6-9bf083f4f01a, params: {refresh=wait_for, index=.kibana, id=index-pattern:e9aaa8c0-527f-11e8-a6f6-9bf083f4f01a, type=doc}
org.elasticsearch.transport.SendRequestTransportException: [es-d1][10.146.0.4:9300][indices:data/write/bulk[s]]
        at org.elasticsearch.transport.TransportService.sendRequestInternal(TransportService.java:608) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.transport.TransportService.sendRequest(TransportService.java:518) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.transport.TransportService.sendRequest(TransportService.java:506) ~[elasticsearch-6.2.4.jar:6.2.4]

....
Caused by: java.lang.IllegalStateException: can't select channel size is 0 for types: [RECOVERY, BULK, STATE]
        at org.elasticsearch.transport.ConnectionProfile$ConnectionTypeHandle.getChannel(ConnectionProfile.java:213) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.transport.TcpTransport$NodeChannels.channel(TcpTransport.java:433) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.transport.TcpTransport$NodeChannels.sendRequest(TcpTransport.java:481) ~[elasticsearch-6.2.4.jar:6.2.4]
        at org.elasticsearch.transport.TransportService.sendRequestInternal(TransportService.java:598) ~[elasticsearch-6.2.4.jar:6.2.4]
        ... 79 more

ENVIRONMENT

kibana 6.2.4
elasticsearch 6.2.4

I have two clusters with below nodes.

Cluster : mycluster1 , m: master node , d : data node, con : coordinating-only-node

ip         heap.percent ram.percent cpu load_1m load_5m load_15m node.role master name
10.146.0.3            8          55   3    0.05    0.08     0.07 m         *      es-m1
10.146.0.4            9          59   5    0.11    0.09     0.07 d         -      es-d1
10.146.0.7            8          67   2    0.14    0.08     0.07 -         -      es-con-2
10.146.0.2            8          61   4    0.07    0.05     0.05 -         -      es-con

Cluster : mycluster2

ip         heap.percent ram.percent cpu load_1m load_5m load_15m node.role master name
10.146.0.6            9          59   5    0.10    0.11     0.08 di        -      es-d2
10.146.0.5            8          59   3    0.04    0.08     0.07 m         *      es-m2

HOW TO REPRODUCE

1.Set cross cluster search setting inside elasticsearch.yml of coordinating-only-node . And startup the node.

search:
  remote:
    mycluster1:
      seeds: ["10.146.0.4:9300"]
    mycluster2:
      seeds: ["10.146.0.6:9300"]

2.From kibana UI , create index_pattern . Click Create index pattern .

QUESTION

I believe this problem is related to below incident. However, I was able to elude this by setting cross cluster search from cluster setting API (Persistent) .

So , my question is should I set the cross cluster search by using cluster setting API for now to elude the error ?


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.