How to get large strings in elasticsearch and kibana


(ajit) #1

Hi,
I am pushing large string values in elasticsearch. But it is not showing in kibana. I have query to update mapping. But it is showing resource_already_exists exception.
I want to update mapping for large strings without deleting index.

PUT cap_log_beta
{
"mappings": {
"doc": {
"dynamic_templates": [
{
"strings": {
"match_mapping_type": "string",
"mapping": {
"type": "text",
"fields": {
"keyword": {
"type": "keyword"
}
}
}
}
}
]
}
}
}

How to fire this query without deleting index. Or Please provide me other way to show large strings in kibana.


(David Pilato) #2

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:

```
CODE
```

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.

Have a look at https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-update-settings.html

That might work but I'm unsure though.
Anyway, your change won't be applied to existing data if that was your intention. It will be applied only for new documents or updated documents.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.