How to hide count in Data Table?

I'm displaying a Data Table. I dont want to display default Count metric.

How to hide it ?

looking for an easy fix ?

Hi @volcano, are you trying to display individual documents or aggregates of documents? If you just want to show the values of two fields for each document, you can use a saved search - just go to discover, select the fields you want and click save in the menu on the top. Then you can add the current view to a dashboard.

I did this .....in this approach , there is one issue.....if the selected fields dont have any data , it shows blank rows in Data Table.

I dont want to show blank rows in my Data Table.

Example:

If you want to exclude these rows, you can add a filter to the saved search (it will be saved along with the selected fields and also applied when the search is embedded on a dashboard):

If your documents contain a dash character instead of omitting the field, you can also add an is not filter.

Yes. Filter is working fine.

After applying filter I get this :

But I did not select any Time field. It has come to this table by default. How do I get rid of this Time field ?

You can do this via the advanced setting doc_table:hideTimeColumn. This will hide the time column for all saved searches. If you want to add them back in some cases, you can manually select your time field and it will add a regular column.

awesome. ..... advanced settings worked !

Only one issue is here ..... I dont want to display column names as partB , partD .

I want to customize it to some meaningful name.

can I rename it ?

I want to rename partB to request_time and partD to response_time.

How to do this ?

That's not possible at the moment without re-ingesting your documents and renaming (or copying) the fields in the source. You can do this with the copy_to parameter in the mapping: https://www.elastic.co/guide/en/elasticsearch/reference/current/copy-to.html

Create a new index with the mapping containing copty_to and then use the re-index to ingest the documents again.

This issue tracks progress on adding the functionality in Kibana itself: https://github.com/elastic/kibana/issues/47659

Install Enhanced table plugin- using this plugin we can hide columns.

How to install this plugin ?

Download this plugin using this link : https://github.com/fbaligand/kibana-enhanced-table/releases
and follow the steps

Every release package includes a Plugin version (X.Y.Z) and a Kibana version (A.B.C).

  • Go to releases and choose the right one for your Kibana
  • launch a shell terminal and go to $KIBANA_HOME/bin folder
  • use Kibana CLI to install :
    • directly from Internet URL : $KIBANA_HOME/bin/kibana-plugin install https://github.com/fbaligand/kibana-enhanced-table/releases/download/vX.Y.Z/enhanced-table-X.Y.Z_A.B.C.zip
    • locally after manual download : $KIBANA_HOME/bin/kibana-plugin install file:///path/to/enhanced-table-X.Y.Z_A.B.C.zip
  • restart Kibana

I dont have access to CLI.
I am using managed service.
I have only access to Kibana UI.

Can it be installed from Kibana UI ?

yes, just use that commands in cmd

You did not get me. I am saying , I dont have cmd or CLI access. I have Kibana UI access.

Can it be installed from Kibana UI ?

ELK is not in your system ?

No, u can't from kibana UI

I am using AWS ELK. This is managed service. I can not log into Kibana instance.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.