How to regenate ui_framework/dist/ui_framework.css


(Gloria Gu) #1

I made some color changes to ui_framework/components/button/index.scss, restart kiabana doesn't see to regenerate ui_framework/dist/ui_framework.css. It is a checkin file...how to regenerate it so it will pickup the changes in the component? Thanks.

I ran the command "npm run uiFramework:build" but has error:

kibana@6.0.0-alpha2 uiFramework:build /home/ggu/500G/kibana
grunt uiFramework:build

Loading "Gruntfile.js" tasks...ERROR

SyntaxError: Unexpected token {
Warning: Task "uiFramework:build" not found. Use --force to continue.

Aborted due to warnings.

npm ERR! Linux 4.10.1-1-default
npm ERR! argv "/home/ggu/.nvm/versions/node/v5.5.0/bin/node" "/home/ggu/.nvm/versions/node/v5.5.0/bin/npm" "run" "uiFramework:build"
npm ERR! node v5.5.0
npm ERR! npm v3.3.12
npm ERR! code ELIFECYCLE
npm ERR! kibana@6.0.0-alpha2 uiFramework:build: grunt uiFramework:build
npm ERR! Exit status 3
npm ERR!


(Shaunak Kashyap) #2

Yeah, you're right that ui_framework/dist/ui_framework.css needs to be regenerated and checked-in.

To regenerate it, run npm run uiFramework:start. This will start up the UI Framework web site, accessible at http://localhost:8020. As part of doing that, it will regenerateui_framework/dist/ui_framework.css`. Then you can check it in.


(Gloria Gu) #3

Thanks shaunak, however I got error complaining about "SyntaxError: Unexpected token {
Warning: Task "uiFramework:build" not found. Use --force to continue.". I checked there is a ui_framework.js under tasks and it has grunt.registerTask('uiFramework:build', function () {...}. Same error if I run " npm run uiFramework:start", can not found the task


(Gloria Gu) #4

I figured out what is wrong, I was using node v5.5.0. The error message threw me off. It just complain about the the task is not there.
Switch to use node v6.10.2
nvm install v6.10.2
however when use that version, it will complain about
Loading "ui_framework.js" tasks...ERROR

Error: Missing binding /home/ggu/500G/kibana/node_modules/node-sass/vendor/linux-x64-48/binding.node
Node Sass could not find a binding for your current environment: Linux 64-bit with Node.js 6.x

Found bindings for the following environments:

  • Linux 64-bit with Node.js 5.x

This usually happens because your environment has changed since running npm install.
Run npm rebuild node-sass to build the binding for your current environment.

The clue is there ...so I ran npm rebuild node-sass
npm run uiFramework:start

for some reason just run 'npm run uiFramework:build' won't build the ui_framework.css file.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.