How to start specified elasticsearch version using command "yarn elasticsearch"?

I am trying to developping a new kibana plugin against kibana 6.2. The steps as below,

git clone kibana
cd kibana
git checkout 6.2
nvm install "$(cat .node-version)"
yarn elasticsearch

The elasticsearch version being started is 6.3.0, but what I want is 6.2.x. How can I start 6.2.x elasticsearch? Thanks.

curl localhost:9200
"name" : "Bnwlgaf",
"cluster_name" : "esvm-dev",
"cluster_uuid" : "ie8sDTDLT3-ITmUE1_Wz3w",
"version" : {
"number" : "6.3.0",
"build_hash" : "0ac6a36",
"build_date" : "2018-03-08T21:18:20.003316Z",
"build_snapshot" : true,
"lucene_version" : "7.2.1",
"minimum_wire_compatibility_version" : "5.6.0",
"minimum_index_compatibility_version" : "5.0.0"
"tagline" : "You Know, for Search"

Hi there, looks like that's an error with Kibana's 6.2 tag. As a workaround, you can install esvm globally and then use it to launch ES 6.2:

esvm 6.2.0

Hope this helps,


Thanks, it works. But only ES 6.2.0 and 6.2.1 are available for 6.2.x. The kibana version being started is 6.2.3 by default.

I configured 6.2.1 in the plugin's package.json,

"kibana": {
"version": "6.2.1"

But I saw the following error message when starting the kibana + plugin,

[warning][plugin] Plugin "example1" was disabled because it expected Kibana version "6.2.1", and found "6.2.3".

So the question is how to run kibana 6.2.0 or 6.2.1?


ES 6.2.0 and 6.2.1 are both compatible with Kibana 6.2.3. I believe you're seeing this error because your getExpectedKibanaVersion method declares 6.2.1 as the Kibana version your plugin is compatible with, and your Kibana version is 6.2.3. If you change that method to declare 6.2.3 then that error should go away.

Hope this helps,

Actually, you should be able to just remove that method entirely, which would be even better.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.