I have an issue in installing x-pack the following text appears whenever I try to install it


(ibrahim) #1

-> Installing x-pack/...
Trying https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/x-pack/2.3.1/x-pack-2.3.1.zip ...
ERROR: failed to download out of all possible locations..., use --verbose to get detailed information
....
for more info in my kibana when I tried to install x- pack I got this response...
bin/kibana-plugin install x-pack
Kibana now contains X-Pack by default, there is no longer any need to install it as it is already present.

Any help would be appreciated


(Bernt Rostad) #2

I don't think Kibana x-pack exists before 3.0, see past releases, which is why that 2.3.1 download link doesn't work.

In order to install x-pack you will need a newer version of Kibana (and thus also a newer Elasticsearch).


(Bernt Rostad) #3

I missed this part which is true of Elasticsearch version 6.3 and newer. For Elasticsearch versions 3.0 to 6.2 you'll still need to install x-pack.


(ibrahim) #4

Thanks Bernt_Rostad ..I just upgrade the Elasticsearch version and everything works perfectly.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.