Import dashboards, searches and visualizations from Kibana 4 to Kibana 5


#1

Continuing the discussion from Kibana 5.0.0-alpha1 Released:

Hi
How can I import Kibana 4 objects (ie dashboards, searches and visualizations) to new Kibana 5?
I tried to use the Export / Import function but without that does't work.
Are the old Kibana 4 json files compatible with new Kibana 5?
K.


#2

Hello,

Can you show errors messages, please ?

Thk,
Diyal


#3

No error message displayed :-/
Maybe in logs files but I don't know where to find them.

Browser: Chrome 51.0.2704.79 (64-bit)
OS: Linux #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24)


#4

I tried with new 5.0.0-alpha3 but same behavior


(Lee Drengenberg) #5

Which specific 4.x version of Kibana and which version of Elasticsearch 2.x were you on?

And I assume you're using the 5.0.0-alpha3 builds of both Elasticsearch and Kibana.

And what exactly happens when you do the import? Does it appear to work but you don't see the searches, visualizations, and dashboards in Kibana? Or do you see them but they don't work?


#6

I use Kibana 4.3.0 build 9369 and Elasticsearch 2.1.0 on my production environement.
I also use Elasticcsearch and Kibana both 5.0.0-alpha3 on my testing environement.
When I do the import the function seems to work. No message is displayed. But my searches, visualizations and dashboards doesn't appear in list.
I did the test using Chrome and Iceweasel.

To set up my testing environment I did as following :

  • download both 5.0.0-alpha3 Elasticsearch and Kibana deb packages
  • installed them on a fresh debian install
  • modified elasticsearch configuration file
  • ran few scripts to create index, mapping and import data from json files

#7

I succeed to import my visualizations and dashboards from Kibana 4.3.0 to new alpha3. When I reimported them a message has been displayed to overwrite existing objects. I assume that was a refreshing problem.


(system) #8