Inconsistent Autocomplete Suggestions in Kibana Dashboard Filter/Control

Hello Elastic Community Team,

I'm currently working on a Kibana dashboard and have encountered an issue with the autocomplete suggestions in one of the dashboard's filter/controls.

The problem is that while selecting the past 30 days and 1 year, the filter/control is populating the expected number of field names. However, when selecting the past 90 days, it's only showing a limited set of field names. This behavior is inconsistent and unexpected.

Here's what I've done so far to troubleshoot:

  • I adjusted the unifiedSearch.autocomplete.valueSuggestions.terminateAfter value in the YML file to increase the suggestion limit, which resolved the issue for the past 30 days and 1 year.
  • I verified the index patterns associated with the data source and confirmed that they are correctly configured and include the relevant fields.
  • I ensured that the required fields are present in the data within the past 90 days timeframe.
  • I refreshed the Kibana index patterns & Cleared caches, but the issue persists.

I'm seeking guidance on possible reasons for this behavior and how to resolve it. Could there be other settings or configurations that could affect the autocomplete suggestions specifically for the past 90 days?

Any insights, suggestions, or advice would be greatly appreciated. If you need additional information about my setup, versions, or steps I've taken so far, please let me know.

Thank you in advance for your help!

Best regards,

The list that is suggested is not guaranteed to be exhaustive. We only request 10 (I believe, possibly 5 in this case) terms, so until you start typing to filter down the list, there's no way to guarantee the value you're expecting will be there.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.