Controls on Dashboards not showing all the options

I've been trying to make use of the Controls in the Kibana Dashboards but it keeps eliminating some information. It's saying to change the configuration on Kibana.yml but I'm using the Elastic Cloud so I'm not sure what to do about it...Anyone?

Here is the message:
Captura de Tela (937)

Hi @SamuelSMendes ,

Could you share what stack version you are using? I don't see an option to change kibana.autocompleteTerminateAfter property from kibana.yml via Advanced Settings UI.

I will double check with the team and let you know.

Regards, Dima

Thanks for reaching out @Dzmitry.

The version is 7.17.3.

The version is 17.7.3.

Are you sure about the version and that you are using Elastic cloud?
Anyway, since original question was about Elastic cloud you need to go to your cloud deployment and change Kibana user settings by adding kibana.autocompleteTerminateAfter with value from 1 to 10000000

Specifies the max number of documents loaded by each shard to generate autocomplete suggestions. The default is 100000. Allowed values are between 1 and 10000000. To learn more, check Configure Kibana. In stack version 7.14.0 or above, use data.autocomplete.valueSuggestions.terminateAfter instead.

More details here

Regards, Dima

1 Like

The version was a mistake, my bad. Once I try it out I return with the outcome, thanks Dima.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.