Terms list is incomplete because the request is taking too long in controls visualization

I was trying to use controls for my visualizations, but it does not load all the values from the selected field. The list doesn't even show half of them.

I've tried increasing the kibana.autocompleteTerminateAfter and kibana.autocompleteTimeout values upto a great extent, but it seems like it's not taking this much time to load the list. Is there anything else I need to do to get the full list?

I'm using Kibana 7.6.2. Here is the snapshot of the same.

kibana.autocompleteTerminateAfter is not a time, but the number of documents considered per shard. What values did you set it to?

You probably did this, but just to make sure: Also, you have to restart Kibana for these changes to take effect.

1 Like

Thanks @flash1293 for your reply.
I've set these values to
kibana.autocompleteTerminateAfter: 300000
kibana.autocompleteTimeout: 1000000

And yes, I restarted Kibana after making these changes.

Also, as I got to know that this request is the simulation of what the Controls visualization is doing behind the scenes. I'm getting the complete output here, I guess. Then what might be the issue with Controls visualization?

How many documents are in your index? 300000 might be too little. I see you have 3 shards, so if you have more than 900000 documents, that would explain the message.

Also, the options panel will never show you the full list at once, when you start typing it will refetch new data based on the input your already entered.

Thanks a lot @flash1293. It's resolved now. :slightly_smiling_face:
I had 6090179 documents in my index.

Plus, I was unaware of the fact that it refetches new data based based on the input. I was considering only the items I could see in the list on the first go.

But, the issue I'm facing now is that the users need to remember everything- the name of the values they are looking for as well as the case, as the search here is case sensitive. And remembering everything is not possible in my case. Can I turn it off from somewhere? And, is it possible to get the full list instead of refetching the values based on the input? Thanks in advance!

1 Like

Configuring the length of the value list is not possible, but it's a known feature request. You can track it here: https://github.com/elastic/kibana/issues/47453

As for case sensitivity - this depends on how the the Elasticsearch mapping is configured. If you want a field to be case-insensitive, you need to put a "lowercase" filter into your analyzer configuration. It's described pretty well in this blog article: https://pranavprakash.net/2017/09/13/case-insensitive-exact-match-search-in-elasticsearch/

1 Like

Thanks a lot @flash1293 for helping me out!

I'm not part of this thread, but this solution helped me. Thanks Joe again

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.