While creating control visualization we are getting warning "Terms list might be incomplete"


We are using elk version 7.10.2. We have created a control visualisation in kibana UI. We noticed that when we selected the options list and after adding the fields it gives the below warning "Terms list might be incomplete because the request is taking too long. Adjust the autocomplete settings in kibana.yml for complete results".

Could you please let us know how to resolve that warning even after increasing the below parameters the warning remains the same
kibana.autocompleteTimeout to 3000 &
kibana.autocompleteTerminateAfter to 500000


Can you try setting autocompleteTerminateAfter to the number of documents in your index?
kibana.autocompleteTerminateAfter specifies the max number of documents loaded by each shard. If you only have one shard, this should equal to the number of documents in your index.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.