Terms may be incomplete because the request is taking too long

I am hosted in the Elastic Cloud and a new subscriber.

I am using the experimental controls filter option (which is awesome) but receiving this error when the pages are loading."Terms may be incomplete because the request is taking too long. Adjust the autocomplete settings in the kibana.yml for complete results."

I have increased the value to be kibana.autocompleteTimeout: 10000 and it doesn't seem like the filter is waiting that long to load the combo box of values for the filter.

Is there another setting that needs to be changed? Or do I need to do a full restart of the nodes, after hitting save it seems like it is restarting the kibana nodes itself?



Yes, there is another setting which is limiting this particular request: kibana.autocompleteTerminateAfter This is the number of documents considered per shard for filling this list - if there are more documents in a single shard, the request will terminate early and show this warning message.

You can try adjusting it, however if you are not missing entries in the list, it might also be fine for your use case to just ignore the warning.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.