Terms list might be incomplete because the request is taking to long

Hello guys,
Can you help me to fix this error
terms list might be incomplete because the request is taking to long. Adjust the autocomplete settings in kibana.yml for complete results.
Im using kibana with 16 RAM to visualize 1 G of data .

Thank you

Hello @Fedi_Ben_Messaoud

Can you tell the version of the Elastic Stack you're using?
Is this happening when you are typing on the Kibana search bar?

We're aware of a possible regression on 7.6.0 and fixed on 7.6.1 (https://github.com/elastic/kibana/pull/58784).

Other reasons might be an overwhelmed Elasticsearch cluster.
Could you please share the output of:

  • GET _cat/fielddata?v
  • GET _cat/nodes?v&h=*
  • GET _cat/indices?s=index&v

I get this problem when i try to get values into a select list .. i can t get all values from my data. and my elastic version is 7.6.1.

Can you please try to run this request on Dev Tools and paste here the full response?

GET openmedic/_search
{
  "size": 0,
  "aggs": {
    "annees": {
      "terms": {
        "field": "ANNEE.keyword",
        "size": 5
      }
    }
  }
}

I think your problem was just temporary... The request takes only 122 ms.

If your Elasticsearch cluster & Kibana are running locally, it might happen that other processes running on your computer stole some resources.

11 G of memory are free :confused:

The query I've asked to run simulates what the Control visualization is doing behind the scenes.

It returned in 122ms.

The message popup shows up when the Control visualization takes more than 1 second to be generated.

Does the warning shows up when you add the Control visualization in a dashboard?
Or it was just a message which showed up just once?

If you want, in kibana.yml you can set kibana.autocompleteTimeout: 10000.

I do not know your configuration but if they're installed locally this is clearly a development setup.
There are your browser and your desktop environment running.

I've suggested to share the results of few commands to understand your current setup.
Did you increase the JVM Heap to 1 or 2 GB? Or you're running with default settings?

Hope it helps.

The problem is that i can t get all years and the problem still exist when i add the visualisation in the dashboard .

Yes i increased th elastic jvm to 4 Gb but i still have the same problem

I think you do not see all the years because you are saving the visualization with some filters already set (see at the top, below the search bar)

The query I've run is limited to 5 years and it matches all the documents. There are only 3 distinct years in all the documents of the index.

You opened this post to ask about the warning message.
I am trying to help and explained why it shows up.

There is no filters.
Thank you for your help :slight_smile:

I need a screenshot or something to troubleshoot

I'm also facing the same issue, for me also, it doesn't seem like it's taking that long to load the list. Plus, I've also tried increasing the kibana.autocompleteTerminateAfter and kibana.autocompleteTimeout values.
@Fedi_Ben_Messaoud Can you please inform me about the solution in case you've resolved this issue?

Sorry i didn t resolve the problem.

I had the same problem, but what i just do was to unselect "Dynamic Options" option and set the number of options (Size) I wanted to show.

That solve the problem for me. Hope that can help you too. @Fedi_Ben_Messaoud

Hello guys .
The solution is to set kibana.autocompleteTerminateAfter to the number of documents in your index.
kibana.autocompleteTerminateAfter is the number of documents per shard.
For exemple if you have 1 shard and one million documents in your index you should add this line in your kibana.yml
kibana.autocompleteTerminateAfter: 1000000

Hello you can try this solution.
Hope that can help you too

Thanks @Fedi_Ben_Messaoud. My problem is also resolved now.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.