Index not taken - Timelion

Hello All,

I have ingested some data inside elastic search and trying to visualize using Kibana Timelion.

.es(index="fx_twofour_outbound",q='*')

But it is not reflecting any output in my graph.

I crossed verified my index name in Elastic search by querying like this:

GET /fx_twofour_outbound/_search

All my data are available inside elastic search.

Other visualization tools are working fine. But I am facing issue with no output in timelion.

Let me know what could be the issue here.

Thanks in advance.

A common reason for data not showing up in timelion is because of the name of your timefield. By default timelion uses @timestamp, but you can change that by specifing the timefield argument.

timelion functions doc

1 Like

If that is the case, I tried giving like this:

.es(index="fx_twofour_outbound,timefield ="TransactTime_Tag_60")

It shows a syntax error.

Can't we specify both the index and timefield together?

.es(index="fx_twofour_outbound", timefield="TransactTime_Tag_60")

A space after ',' is the reason for failing so far?

Strange behaviour.

I actually changed the fields and retrieved data like this

.es(timefield="TransactTime_Tag_60",index="fx_twofour_outbound")

It worked.

Just cross verified. Both the query results in same output.

Thanks a lot.

If you look closely at the code you posted, you weren't properly enclosing your index name within double quotes. So the parser thought your index name was 'fx_twofour_outbound,timefield =' and then didn't know what to do with 'TransactTime_Tag_60"'. :wink:

That's really bad.

Unexpected and not noticed at all till you mentioned it now.

Bad code and silly mistake.

Thanks for pointing it out.

Happy to help!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.