About Timelion


(Shreyanshu Pare) #1

When i write .es(index='alljson*'), it is not reflcting,not showing any graph constant at 0. I m using Kibana-5.4.0


(Mark Walkom) #2

Is there data in the index? Is it time based? What is the field with the time called?


(Shreyanshu Pare) #3

yes,Data is there.
ExchangeName:EXMO CurrencyPair:DSHBTC MachineTime:28-05-2017_16:53:21.403850 TradeTime:28-05-2017_16:05:00.000000 TradeId:12021032 TradeSide:buy Price:0.052 Volume:0.014 TotalBase:0.001 _id:AVxTJhwmxL_0zZk0O0uU _type:docs _index:alljson _score:1

This type of data is there.


(Mark Walkom) #4

You probably need to set timefield=MachineTime.


(Shreyanshu Pare) #6

Expression = .es(index=alljson,timefield= MachineTime)
Error is showing
Timelion: SyntaxError: {"type":"incompleteFunction","function":"es","location":{"min":1,"max":4},"text":".es"}


(Mark Walkom) #7

You need to remove that space, that was a copy-paste mistake.


(Shreyanshu Pare) #8

ERROR:-

Fielddata is disabled on text fields by default. Set fielddata=true on [MachineTime] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.

This Error is coming i think my machine time is in string format or some otherError? Please Suggest me.
What things i have to change in my data?


(Shreyanshu Pare) #9

When i upload the data in Elasticsearch, at that time i have to mention there
("fielddata": true),
is it correct ?Please Suggest me,
Thanks


(Shreyanshu Pare) #10

This Problem is solved i changes my MachineTime based on @ timefield Schema.

from that side
http://momentjs.com/docs/#/displaying/format/


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.