Initial logon after installing x-pack does not accept default credentials

Folks I'm following the install instructions to the tee only difference is I'm not using loopback addresses, my poc needs to install on a physical cluster

all components are 5.2, have 4 nodes running, installed x-pack and then trying the 9200 port - and the default credentials just keep recalling the dialog box.
the log below is to show my cluster.

full cluster log is here

Bottom of page

[2017-03-18T22:58:49,164][INFO ][o.e.c.s.ClusterService   ] [nn775] detected_master {sn776}{86Pxnnt8RA-X5CwmwdrqSQ}{K9G9k4PyTRSdcfOGwn7sHg}{}{}, reason: zen-disco-receive(from master [master {sn776}{86Pxnnt8RA-X5CwmwdrqSQ}{K9G9k4PyTRSdcfOGwn7sHg}{}{} committed version [61]])
^X[2017-03-18T22:58:50,169][INFO ][o.e.d.z.ZenDiscovery     ] [nn775] master_left [{sn776}{86Pxnnt8RA-X5CwmwdrqSQ}{K9G9k4PyTRSdcfOGwn7sHg}{}{}], reason [failed to ping, tried [3] times, each with  maximum [30s] timeout]
[2017-03-18T22:58:50,170][WARN ][o.e.d.z.ZenDiscovery     ] [nn775] master left (reason = failed to ping, tried [3] times, each with  maximum [30s] timeout), current nodes: nodes:
   {nn775}{NbAK8UxdTKG7kgMuqzhE5g}{jGs4JBxcQKiFO0PVRwXx9w}{}{}, local
   {sn776}{86Pxnnt8RA-X5CwmwdrqSQ}{K9G9k4PyTRSdcfOGwn7sHg}{}{}, master


Ok I'm happy to report some progress here...I figgured the incorrect credentials were cached somewhere. So I

created a new data directory
renamed the old data directory
renamed the cluster
shutdown ES on all 5 nodes
installed x-pack on all 5
rebooted all
now the default credentials work

Im moving on to the next steps of deploying security

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.