Install issues with Kibana3 vs elasticsearch 0.19.11


(Alex Piggott) #1

I downloaded the latest Kibana3, popped it on a tomcat instance sharing
space with my elasticsearch (0.19.11) instance and tried to connect (both:
using an ssh tunnel to connect localhost:9200 back to the server, and
opening port 9200 in the firewall)

In both cases, the browser makes a call to _nodes (eg returns
"{"ok":true,"cluster_name":"infinite-dev","nodes":{"Yup-Cmn0QwCrkYI6l7SdRw":{"name":"Firefrost","transport_address":"inet[/10.113.42.186:9300]","hostname":"ip-10-113-42-186","http_address":"inet[/10.113.42.186:9200]"}}}")

and then returns the following error:

TypeError: Cannot call method 'split' of undefined at
http://SERVER/kibana-3.0.0/app/app.js:22:11260http://dev.ikanow.com/kibana-3.0.0/app/app.jsat he (
http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:7:20041)
at Function.Yb (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.js
SERVER http://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:7:7025)
at http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:22:11204
at i (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:458)
at i (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:458)
at http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:1014
at Object.f.$eval (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.js
SERVER http://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:6963)
at Object.f.$digest (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.js
SERVER http://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:5755)
at Object.f.$apply (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.js
SERVER http://dev.ikanow.com/kibana-3.0.0/app/app.js
/kibana-3.0.0/app/app.js:9:7111)

I don't see any other calls back to elasticseach

I couldn't find a statement anywhere of which versions Kibana3 is
compatible with - does it just need a later version (anyone know the
earliest with which it is compatible, out of curiosity; though I'm planning
to move to 1.0 anyway soon), or am I doing something wrong

Thanks for any insight/help anyone can provide!

Alex

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ed77f1e7-547d-4c87-b23f-ee97dece9533%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Alex Piggott) #2

Never mind, I'm an idiot, it clearly mentions it needs 0.90.x in the README
:frowning:

On Wednesday, March 19, 2014 12:49:46 PM UTC-4, Alex at Ikanow wrote:

I downloaded the latest Kibana3, popped it on a tomcat instance sharing
space with my elasticsearch (0.19.11) instance and tried to connect (both:
using an ssh tunnel to connect localhost:9200 back to the server, and
opening port 9200 in the firewall)

In both cases, the browser makes a call to _nodes (eg returns
"{"ok":true,"cluster_name":"infinite-dev","nodes":{"Yup-Cmn0QwCrkYI6l7SdRw":{"name":"Firefrost","transport_address":"inet[/
10.113.42.186:9300]","hostname":"ip-10-113-42-186","http_address":"inet[/
10.113.42.186:9200]"}}}")

and then returns the following error:

TypeError: Cannot call method 'split' of undefined at
http://SERVER/kibana-3.0.0/app/app.js:22:11260http://dev.ikanow.com/kibana-3.0.0/app/app.jsat he (
http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:7:20041)
at Function.Yb (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.js
SERVER http://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:7:7025)
at http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:22:11204
at i (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:458)
at i (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:458)
at http:// http://dev.ikanow.com/kibana-3.0.0/app/app.jsSERVERhttp://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:1014
at Object.f.$eval (http:// http://dev.ikanow.com/kibana-3.0.0/app/app.js
SERVER http://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:6963)
at Object.f.$digest (http://http://dev.ikanow.com/kibana-3.0.0/app/app.js
SERVER http://dev.ikanow.com/kibana-3.0.0/app/app.js/kibana-3.0.0/app/app.js:9:5755)
at Object.f.$apply (http://http://dev.ikanow.com/kibana-3.0.0/app/app.js
SERVER http://dev.ikanow.com/kibana-3.0.0/app/app.js
/kibana-3.0.0/app/app.js:9:7111)

I don't see any other calls back to elasticseach

I couldn't find a statement anywhere of which versions Kibana3 is
compatible with - does it just need a later version (anyone know the
earliest with which it is compatible, out of curiosity; though I'm planning
to move to 1.0 anyway soon), or am I doing something wrong

Thanks for any insight/help anyone can provide!

Alex

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c6a2f998-89a9-4794-bdf8-15d1dcd26aae%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3