Install logstash-input-fluentd plugin doesn't work (logstash 5.x)


#1

I have logstash 5.4 (latest release) installed through RPM.
I cannot successfully install logstash-input-fluentd plugin with this version because it complains about:

Bundler could not find compatible versions for gem "logstash-core":
In snapshot (Gemfile.lock):
logstash-core (= 5.4.0)
In Gemfile:
logstash-core-plugin-api (>= 0) java depends on
logstash-core (= 5.4.0) java
logstash-input-fluentd (>= 0) java depends on
logstash-core (< 3.0.0, >= 2.0.0.snapshot) java
logstash-core (>= 0) java

From the documentation in rubygems.org (https://rubygems.org/gems/logstash-input-fluentd/versions/2.0.4), the lastest version (2.0.4) of the logstash-input-fluentd plugin
should work with logstash-core = 5.4.

Is there an official workaround to install this plugin with logstash 5.x version?

Is it suggested to send the logs directly from fluentd to elasticsearch?
(I'd prefer to use Logstash as the centralized logging since we are using it for receiving other logs too)

Thanks.


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.