Is Kibana 4.2 still supported?


(Sergey Kozlov) #1

Hi,

First and foremost I would like to thank you for providing a great piece of software to the opensource world. Your work is greatly appreciated.

I'm the maintainer of Kibana 4.x ports for FreeBSD.
I've noticed that several last updates included 4.1, 4.3, 4.4 and 4.5 version bumps, but not 4.2. All the versions are now running on node 4.x, but not 4.2.
According to the support matrix Elasticsearch 2.0, which Kibana 4.2 is compatible with, is still supported, but is it the same for Kibana itself?

If Kibana version 4.2 is no longer maintained I would prefer deprecating the port and suggesting users to move to newer versions to keep them on the safe side. If it is maintained - then why wasn't it updated to use node 4.x as other versions?

Thanks,
Sergey


(Court Ewing) #2

4.2 and 4.3 are still supported in the sense that we'll answer questions and provide support services for them, but we do not intend to have any future 4.2 or 4.3 releases.

We occasionally ship updates to 4.1 purely for legacy reasons - it's the last release of Kibana that supports Elasticsearch v1.

Edit: We strongly recommend that people run the latest stable version, which is currently 4.5.0.


(system) #3